Highlighted
tjbaezid
1 Copper

Dell Inspiron 5458 pluged-in not charging

 I have tried lots of process to charge my laptop battery. I have 45 wt adopter. 
My friend have same model laptop. SO I took his adopter tried to charge my battery but it's not working . But when I put my friend's battery and charger on my laptop, his battery is charging. I also try my battery on his laptop with his adopter and also mine adopter but battery is not charging. Currently  my laptop working with my adopter power and battery level 0.  
So what's the problem? Do I need to change both my battery and adopter  ?? 

Additional Info: Windows 7 64bit 

Thanks
 

0 Kudos
1 Reply
Moderator
Moderator

RE: Dell Inspiron 5458 pluged-in not charging

Hi TJBAEZID,

Based on your description, I would suspect a battery failure. The battery might have reached the end of its rechargeable cycle or might have failed. Since another battery is working fine on the system, I would suspect the battery on your machine with the fault.

Restart the system and press f2 key to enter BIOS - check the adapter status in BIOS with and without the adapter plugged in. Also, wiggle the adapter cable at the end and see if the status changes in BIOS at any point. Check the battery health in BIOS (if applicable).

Restart the system and press f12 key on startup - choose diagnostics. Let it run the diags and if you encounter any errors - make a note of the complete error and report the same to us. These are onboard diagnostics and they might possible pick some error if the hardware is not functional. Also, run an extended / thorough tests on the HDD and memory to check for any possible errors. 

If the system is under warranty, Please click my DELL-username and write me a private conversation with the service tag and your contact details(Name, Phone#, Address and Email). If there is no warranty, then you could contact our team to get a quote for a paid service call - http://dell.to/1vnT6CQ

Let us know if you have any other queries.

Thanks and Regards,
DELL-Rishi
Social Media and Communities Professional
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

0 Kudos