Turboren
1 Nickel

Dell Inspiron 7559 Laptop - Display flashing

Hi, I had bought my laptop in late September of 2016 and am just outside of my warranty period.  I use this laptop for school work (involves some autocad and waveforms 2017 work).  Recently the display has started flashing black with it being more off than on.  This makes the laptop unusable for me as I now have to connect it to an external monitor to use it.  With the desktop extended or cloned the external monitor works fine through HDMI and the laptop screen flashes and pulses.  Some times the screen works fine for a minute and then will go back to flashing.  The first couple of times it happened was while in fullscreen mode watching youtube.  I would close chrome and it would start working normally.  This put me down a software path.  I have tried updating both the intel video drivers and the Nvidia drivers.  My current drivers are Nvidia: 22.21.13.8205 and Intel: 21.20.16.4627.  I recently also updated my BIOS drivers to 1.2.4 to try to solve this issue.  No adjustments I have made in software has made it better and it seems to be getting worse with time.  The screen on this one is the 4k touchscreen.  I mostly keep it in 1080p though due to software compatibility issues. Even with the screen flashing the touchscreen still functions normally and tracks at all corners.  I am hoping this is not a hardware issue as I will be extremely disappointed if that is the case.

Thanks, 

Michael

0 Kudos
1 Reply
Turboren
1 Nickel

RE: Dell Inspiron 7559 Laptop - Display flashing

Just went into the preboot test screen to test the screen.  #1 for some reason it shows as 1024x768 on that screen.  The display works fine while on that screen, when it shows the horizontal and vertical colored bars, and while the screen is flashing the solid colors.  It messes up and flashes as soon as the box comes up asking if I saw the test successfully.  This strikes me as weird that the test is good until the confirmation box pops and then if freaks out.  Anyway just adding more data into the issue to try to help get this resolved.

0 Kudos