Highlighted
limelight05
1 Copper

Dell Inspiron 9400 does not function without power adapter

Here's the scoop.....

My existing battery was near the end of it's usable life (approximately 28 months of use.........not bad).  Laptop diagnostics recommended replacing it.  OK, no problem.

Replaced the existing battery with a new battery.  The new battery was "made by Dell and distributed by Dell" through Amazon.  It says Dell on the battery and includes the typical Dell nomenclature.  Hmm, did I get taken on this?

Plugged in power adapter and booted.  The Inspiron setup recognized the battery, charged it to (96%) and indicated it functioned properly.  Inspiron recognized power adapter to be 90 watts.  Blinking green LED indicated it was charging the battery.  Everything is great, right?

Unplugged the power adapter and the Inspiron went dead, I mean really dead.  No function of any hardware, no hybernation, no sleeping, no eyes half open.  Just dead.

Removed battery and checked LEDs.  All five are green and steady.  No error indication.

Plugged power adapter back in and rebooted.  After Windows Vista recovered (because it recognized that it shut down abruptly) everything was fine.  Put the new battery back in.  It is immediately recognized and starts to charge (96%) like before.  Unplugged the power adapter again and the Inspiron went dead.  Again, plugged it back in and rebooted.

Went through the Dell support guidelines and they recommended updating BIOS.  Hmm.  A little risky knowing that there is a potential underlying problem, but what else am I going to do?  Updated BIOS.  Ran through the same scenario.  No harm done, but still the same outcome.  It's past warrantee, so there is no tech support unless I get out the credit card.

What am I doing wrong?  I also tried different power option settings with no result.

Thanks in advance.

0 Kudos