Highlighted
abeer.d90
1 Copper

Dell Laptop stuck on 'Dell' loading screen

hello,

Im having some issues with my laptop (studio 1555). It was working just fine sometime back until a blue screen of death (bsod) appeared and the laptop turned itself off. When i tried to turn it on again it got stuck on the dell loading screen. It would load up to about 60% and stay there. Pressing F2 or F12 doesnt do anything. I tried pressing Esc and it took me to another screen which displayed the specs of my system:

cpu = 1 processors Detected, Cores per Processor = 2
Intel (R) Core(TM) 2 Duo CPU   T6500 @ 2.10GHz
4094M System RAM Passed
2048 KB L2 Cache
System BIOS shadowed
Video BIOS shadowed

It also says "Press <F2> to enter setup at the bottom of the screen, when i press F2 nothing happens, a message appears "Entering SETUP..." and it just stays like that.

I have tried removing ram and cmos battery but no luck.

I cannot enter my bios or safe mode, as i previously mentioned that when i press f2 or f12 nothing happens. 

0 Kudos