Laptops General - Read Only

Start a Discussion
2 Bronze
2 Bronze

Dell Latitude E7250 overheat

Hi,

So I have Dell Latitude e7250 with i7 CPU (5600) and the CPU temperature is reaching 103 C when it's under load. 

I did the self test and I got a warning about the temperature out of range issue. 

Is it normal for this laptop ? Please note that I'm not getting any auto restart or shutdown, just seeing overheat using HW monitor SW.

Replies (5)
5 Tungsten

Hi Aghanem

Thanks for writing to us.

Is there is a performance lag? Is the machine overheating to the extend that you cant touch the machine?

If the bios is not up to date, please do the same and keep us posted.

Do provide us your system tag#, email address and name via private message,by clicking on my name

in blue and then select send a private message

Regards

DELL-Hemalatha P
Social Media Support
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

2 Bronze
2 Bronze

PM sent with my details.

Bios is up to date , ver A14.

CPU is throttling @ 102 c Degrees and causing a huge performance drop.(refer to attached Intel tuning tool results , notice that it's reporting a CPU throttling due to high temperature).

I'm only running some development apps and emulator, CPU temperature is ranging between 100 and 104 c.

I sent to laptop today to dell support and they applied a new thermal paste which makes no difference so far.

They requested a new heat sink part and return back my laptop until they receive the parts.

2 Bronze
2 Bronze

Hello,

I have the same problem. Have you done something to fix it? In what percentage of the battery starts you to warm up?

Regards,

David

2 Bronze
2 Bronze

Hi David,

The issue is not fixed yet. Dell replaced the motherboard including CPU , heatsink and fan and the issue is still the same.

This model have a weak cooling, the only thing you can do to avoid hitting the 100c+ is to turn off Intel turbo boost either from BIOS --> perfromance or by adjusting the power options -->advanced-->Processor  power managment --> maximum power state--> change  to be 99% instead of 100%

2 Bronze
2 Bronze

Maybe some performance lag, or your laptop need to clean and take MX4 cooling to reduce the temp

Top Contributor
Latest Solutions