Highlighted
CMiller513
1 Nickel

Dell Latitude e7240 Loses Network Connection While Docked

Jump to solution

Computer: Dell Latitude e7240
OS: Windows 7 x64

I have a  Dell Latitude e7240 running Windows 7 that loses network connection after it's woken up from sleep mode on a dock. 

Typically, I will dock the laptop, boot up the computer and use it for a bit. After I walk away from it, the laptop will go to sleep. I will come back and wake the computer up, but the network connection doesn't come back. The computer searches for a network but doesn't connect to anything. I will have to power down the laptop, undock, redock and reboot to get the network back. 

I've tried several different docks and it is occurring on all of them. All of the drivers are installed and the network adapters are all disabled except for the ethernet adapter. If I plug the ethernet cable directly into the laptop, the network connection functions properly.

Any advice or suggestions on how to resolve this?

0 Kudos
3 Replies
Jardelsf
1 Copper

RE: Dell Latitude e7240 Loses Network Connection While Docked

Jump to solution

Hi CMILLER513,
My company bought a bunch of these laptops and all of them are with this same issue.

Have you found any solution?

Every time the laptop woke up from sleep or hibernate mode, the network interface doesn't get IP.

So We need to disconnect and them reconnect the network cable to it works again.

0 Kudos
CMiller513
1 Nickel

RE: Dell Latitude e7240 Loses Network Connection While Docked

Jump to solution

Hey Jardelsf,

I did find a solution!

1) Make sure all your drivers are downloaded and installed

2) Go to your network connections (Control Panel\Network and Internet\Network Connections)

3) Right click on your local area connection and go to properties

4) Inside of the properties window, click on configure then power management.

5) Make sure all of those boxes are unchecked. There should only be 3 boxes

6) Reboot machine, then you should be good....good luck!

Jardelsf
1 Copper

RE: Dell Latitude e7240 Loses Network Connection While Docked

Jump to solution

Hey CMILLER513,

Your solution didn't work at the first moment, so I tried removing Intel Advanced Services and Intel PROSet from Intel Network Connections installer at Programs and Features, leaving just the adapter drivers installed.

After that I was able to uncheck the three checkboxes at adapter's power management tab.
Now it's working like a charm!

Thank you so much!

I spent lot of hours with Dell support without success until I found your post!

0 Kudos