zweigoh
2 Bronze

Re: Dell Precision M4700 (Windows 7 pro) won't boot after configured with UEFI and Secure Boot

Jump to solution

Yes. It works for me.

It's gotta be the AMD Firepro graphics card that lacks the UEFI driver. Nvidia card doesn't have this boot error problem since they have Optimus technology enabled which uses integrated with Secure Boot (useless they uncheck the Optimus and use discrete card entirely)

Let the Dell support team know the cause of this problem and make this thread Sticky!

0 Kudos
zweigoh
2 Bronze

Re: Dell Precision M4700 (Windows 7 pro) won't boot after configured with UEFI and Secure Boot

Jump to solution

By the way, which is the correct way to install Windows 8? Using the UEFI option + Legacy Option ROM or BIOS + Legacy Option ROM?

Thanks

0 Kudos
bennykanezza
2 Bronze

Re: Dell Precision M4700 (Windows 7 pro) won't boot after configured with UEFI and Secure Boot

Jump to solution

I'm going to do UEFI + Legacy Option ROM.  The UEFI stuff boots faster (apparently) and is the way of the future!  And if Dell fix this Secure Boot problem, maybe with a video bios or something, then you can enable Secure Boot without having to reinstall your OS.  At least I think it works like that 🙂

0 Kudos
zweigoh
2 Bronze

Re: Dell Precision M4700 (Windows 7 pro) won't boot after configured with UEFI and Secure Boot

Jump to solution

Here's i i face right now:

I enable UEFI mode, Insert Windows 8 USB drive, setup windows 8,tried format the 3rd HDD partition (there are 3 partitions,one of it is OEM,one is Recovery,one is OS) but it says something like this, "this hard drive has MBR and EFI system can only install on GPT disk).

This EFI this is killing me!

Do i need to delete all the partition and resize it again?

0 Kudos
zweigoh
2 Bronze

Re: Dell Precision M4700 (Windows 7 pro) won't boot after configured with UEFI and Secure Boot

Jump to solution

Solution:

Delete all the partition, resize to the one that you need. Install Windows 8 Pro.

Good luck!

0 Kudos
bennykanezza
2 Bronze

Re: Dell Precision M4700 (Windows 7 pro) won't boot after configured with UEFI and Secure Boot

Jump to solution

Yeah, the UEFI depends on a different way of storing the partition table on your hard drive.  Hence it complaining about needing GPT.  That means you will lose your recovery partition and everything.  If you didn't want to do that you can just install it via normal BIOS.  Otherwise yes, you need to delete everything and start the drive from scratch.

I burned my recovery disks just in case, and then I'm deleting everything on the drive and starting it again.  I won't be doing it till I get home later though so I haven't tried anything yet!

Hope it goes smoothly from now!

0 Kudos
zweigoh
2 Bronze

Re: Dell Precision M4700 (Windows 7 pro) won't boot after configured with UEFI and Secure Boot

Jump to solution

I had successfully install the Windows 8 Professional on a fresh HDD on UEFI mode (delete all the partition and start from scratch).

Now Windows 8 Professional doesn't activate! Because it was thinking i install it in a new system and not upgrading from a XP,Vista or 7.

Way to go Dell ! The original partition of Windows 7 was on BIOS mode (not UEFI). So your only option is to "upgrade" using BIOS mode.

And if you want to install Windows 8 on UEFI mode, you need to reinstall Windows 7 from scratch using UEFI and upgrade it to Windows 8.

This is just what i been through. Guess i need to re-install Windows 7 from scratch and update it to Windows 8 on UEFI mode.

0 Kudos
zweigoh
2 Bronze

Re: Dell Precision M4700 (Windows 7 pro) won't boot after configured with UEFI and Secure Boot

Jump to solution

Work around for Windows 8 activation failure.

  • Open regedit by pressing Windows-q, entering regedit and selecting the result from the list of hits.
  • Navigate toHKEY_LOCAL_MACHINE/Software/Microsoft/Windows/CurrentVersion/Setup/OOBE/
  • Change MediaBootInstall from 1 to 0
  • Go back to the start screen and enter cmd there.
  • Right-click Command Prompt and select to run it as administrator.
  • Type slmgr /rearm on the command line and hit enter.
  • Reboot Windows now.
  • Run the activation utility afterwards, enter your product key to activate Windows.

www.ghacks.net/.../windows-8-upgrade-clean-install-possible

0 Kudos
Anonymous
2 Iron

Re: Dell Precision M4700 (Windows 7 pro) won't boot after configured with UEFI and Secure Boot

Jump to solution

I had the same problem with M4700 and your solution worked perfectly.

Big THANK YOU!

0 Kudos
BTSADMIN
1 Copper

RE: Dell Precision M4700 (Windows 7 pro) won't boot after configured with UEFI and Secure Boot

Jump to solution

Reset BIOS Settings Instructions for Dell Precision M4700

 

  • Clear & diffuse laptop memory / Change BIOS settings / Boot laptop

 

1.            Unplug power cord

2.            Unplug laptop battery

3.            Open bottom cover & unplug CMOS battery

4.            Press power button several times to diffuse motherboard

5.            Wait 2-3 minutes with nothing plugged in for power or memory

6.            Next, connect ONLY the power cord

7.            Press power button and then F12 button repeatedly

8.            On menu screen select ‘change settings’ (to go into BIOS)

9.            In BIOS setup menu, select ‘Load Defaults’ at bottom

10.          Select ‘Post Behavior’ and select ‘Minimal Boot’

11.          DON’T click ‘Apply’ and ‘Exit’ yet! FIRST, plug in CMOS battery & laptop battery again!

12.          Select in BIOS menu at bottom ‘Apply’ and then, ‘Exit’

 

Conclusion:

 

Laptop will exit BIOS and power up for a moment, then cut off. Let it do this cycle first (it may do this twice). Then, when it auto shuts off, press power button to boot laptop normally with working settings.