SvenC
2 Bronze

RE: Dell Precision M6800 with AMD Firepro M6100 graphics issues

I need Hyper-V as I use VMs on my m6800 for development.

I gave up on AMD and replaced it with nvidia, problem gone.

0 Kudos
mgiovannan
1 Copper

RE: Dell Precision M6800 with AMD Firepro M6100 graphics issues

I also need Hyper-V. I gave up on Dell and AMD some time ago replaced with HP and nvidia.

Problem gone.

I've been taken for a fool by the customer services for too long, and no solution have been found in more than a year. I'll go give my money to someone that deliver a descent product. And from what i have seen, dell is not that compagny.

0 Kudos
Highlighted
petsoe
1 Copper

RE: Dell Precision M6800 with AMD Firepro M6100 graphics issues

Thank you so much. This was exactly the issue for me.

I had installed Visual Studio 2015 Update 2 (KB3022398) and Update for Microsoft Visual Studio 2015 (KB3151378) and my grahpics was totally garbled after installing these 2 updates and restaring PC.

Turning off Hyper V fixed the issue.

BillVo
1 Copper

RE: Dell Precision M6800 with AMD Firepro M6100 graphics issues

My M6800 has an Intel i7-4700MQ processor, 24GB of RAM, and AMD FirePro M6100 GPU.  I'm running Windows 8.1.


I keep this running for weeks without a restart so the DisplayPort garbage hasn't happened much.  Yesterday I decided to track it down.

If I tell Windows to restart, monitors connected to internal DisplayPort and E-Port Plus Video 2 DisplayPort show random images starting just before Windows is ready for login.  E-Port Plus Video 1 DisplayPort doesn't have this symptom.  If I instead shutdown and power-up, the displays are normal.

I've swapped the monitors on my dock DisplayPorts.  I've tested with only one monitor -- on the internal DisplayPort instead of the dock.  I've tried Dell's DP-DVI adapter instead of DP-DP.  The problem is consistent.  Any monitor connected to a DisplayPort other than E-Port Plus Video 1 will show a random image upon restart.

I found it interesting that even when the display shows random images, the mouse cursor is clear.  The pointer is not affected.

Tags (3)
0 Kudos

RE: Dell Precision M6800 with AMD Firepro M6100 graphics issues

Spoke with Dell CS; it took 2 calls, but I got did get a very proficient representative who consulted with his supervisor and spoke well about this case. (The first rep turned me away stating that I needed to re-install Windows 8 in order for him to discuss the matter with me).

CS verified that AMD needs to provide resolution and driver updates to properly support Hyper-V.  The M6800 is a server class machine and it is intended to run Hyper-V; so they do consider it a flaw.

As a result of my support ticket, AMD as well as Dell Technical Support teams are being escalated.  Apparently this is a known issue dating from January, 2016; however there is just a single report of a customer complaint (probably someone else in this thread).  Nevertheless, they will be getting back to me in 24h with a status resolution update.

0 Kudos
SvenC
2 Bronze

RE: Dell Precision M6800 with AMD Firepro M6100 graphics issues

Good luck. Hope you get a solution for this. Really bad experience with AMD in this case. Might go for nvidia next time...

0 Kudos
RuedigerE
1 Copper

RE: Dell Precision M6800 with AMD Firepro M6100 graphics issues

I had the same issue with my M6800 and AND Fire Pro. The problem on my Notebook was that after installation of VS the Hyper-V Option was active. Hyper-V and Firepro obviously doesn't work together. 

I don't know if your Problem is solved in between. I simply deactivated the Hyper-V option and everything worked fine.

Ruediger

0 Kudos
Glenn Leber
1 Copper

RE: Dell Precision M6800 with AMD Firepro M6100 graphics issues

I just started a new job and they issued me a M6800

Had similar issues with the display port.

Tried several different AMD drivers and some kind of helped until reboot then it would come back.

After several tries I updated the intel display driver to the latest one and my issue went away.

Rebooted several times, loaded Hyper V and other applications no issue

One of the things I was seeing was extra displays showing up. After installing the intel driver I have the correct amount of displays and no more garbled displays.

Name Intel(R) HD Graphics 4600

Name AMD Radeon HD 8950

Loaded the latest driver from the dell site for both cards and I don't seem to be having any issues

0 Kudos
saroku24
1 Copper

RE: Dell Precision M6800 with AMD Firepro M6100 graphics issues

Do you mind sharing your case/support ticket ID?  I think if all of us created a ticket and referenced yours, this might get more attention.. I have this same issue.. created a ticket, sent it in, they reimaged it, and then deduced there was nothing wrong.  My boss got frustrated and had Dell send it back... but I'm wanting to get it fixed.. I'd prefer they just use the warranty ("money") and swap out the video cards.  My unit is about a year old now with a 3yr.

Was there a solution to your ticket?  If so, that's even better, 'cause then they can use that same solution to resolve new cases.

0 Kudos
BillVo
1 Copper

RE: Dell Precision M6800 with AMD Firepro M6100 graphics issues

My service request was number <Admin Note: removed per privacy policy~RK>.  Dell replaced the AMD FirePro video with NVIDIA Quadro K3100M.  In the end it was good, but it took several tries.  

1. The first video replacement killed the motherboard.  (V2)

2. Replacing both the video  and motherboard was partial success, with battery not working properly. (V3, M2)

3. The motherboard was replaced again and the battery worked, but the Wi-Fi switch was disconnected so no Wi-Fi.  (M3)

4.  Wi-Fi switch reconnected.

If my count is accurate, I'm on my third motherboard and third video card and all is well.  The laptop runs Hyper-V and don't lose video functionality on a reboot.  Ask for "depot repair" if you prefer to have everything working the first time and can give up your laptop for a few days.

One interesting note regarding DisplayPort with M6800.  When docked, the DisplayPort on the laptop works or doesn't work depending on which video card you have--works with AMD not with NVIDIA.  I was connecting my third monitor to this port and it stopped working after the NVIDIA fix.  

I had an older E-Port Plus docking station that had USB 2.0 and DisplayPort 1.1.  I replaced this with a newer E-Port Plus.  The new EPP works with a StarTech DisplayPort MST hub, so I can connect two DP monitors to Video 2 and one to Video 1, for a total of 3 again.

0 Kudos