norrierfc
1 Nickel

Dell TB16 - Latitude 7370 various issues

We have a Tb16 dock in at the moment for trial. It is very unstable on our Latitude 7370's

We've installed all the latest drives from Dell, updated firmware on both the Dock and the laptops but still face issues

The main problem problem as far as I can see is the ASMedia USB 3.0 Extended Host Controller Driver , when installed the dock will just not work with ethernet or USB. No connection at all. If we remove this driver and allow Microsoft to install it's own version then the USB and Ethernet ports work OK however then another issue occurs, the connection constantly drops out over and over again , internet drops out, USB stops working (with the familiar sound you hear when you disconnect a USB device from a PC) and then reconnects again, this happens over and over again. I use the NIRSOFT tool USBLogView and there was hundreds of connects and disconnects over a few hours

The only way we've managed to get it stable is to either put the device into air plane mode or put the power setting on the WiFi adapter down to 1 which obviously isn't a good work around. Alternatively if we do not use the ethernet port then the USB works fine

When you install the ASMEDIA driver from the Dell pack you end up with a unknown device which I can't find any drivers for

http://imgur.com/2VVUXLY

This isn't just one one laptop either, this is on all our Latitude 7370's we've tested

0 Kudos
9 Replies
Community Manager
Community Manager

RE: Dell TB16 - Latitude 7370 various issues

Hi norrierfc,

Thanks for posting.

Here is some information you may find helpful:  http://dell.to/2t2t64I


Dell-Robert P
Social Media Support
#IWork4Dell
To help us troubleshoot, please send us the Dell service tag number via a private message
Would you like to be a Dell Community Rockstar?


0 Kudos
Highlighted
norrierfc
1 Nickel

RE: Dell TB16 - Latitude 7370 various issues

Hi

Thanks for that, I should have mentioned originally that I've been through all the troubleshooting guide on that page, updated the firmware etc (and indeed as mentioned the ASMedia USB 3.0 Extended Host Controller Driver actually completely breaks dock functionality all together , other than monitor i.e. no mouse or keyboard)

The problem definitely seems related to the ethernet port on the dock as the minute I attach it that's when I start to get USB port disconnects and Ethernet disconnects back to wifi, then reconnects. then disconnects and so on unless of course I put laptop into airplane mode or turn the power down on wifi to lowest setting.

I've got an call logged with Dell tech support now but would be interested to know if anybody else has seen a similar issue since this is happening on all our laptops we purchased albeit we've only had one dock to test (so therefore hopefully just a faulty dock...)

0 Kudos
jetshine
1 Copper

RE: Dell TB16 - Latitude 7370 various issues

I am having the same issue, TB16 with an XPS 13 9350.  The dock randomly disconnects for a few seconds, then reconnects (and I get some notifications about "new thunderbolt topology", etc.).  The time between disconnects is very random, sometimes 30 minutes between occurrences, sometimes 2 minutes.

I also ran into the same problem with the ASMedia USB host controller driver, so I uninstalled it and have been using the generic Microsoft driver.

The only work-around that seems to work for me is leaving the lid open on the laptop - I have not seen the disconnects happening in this configuration.  Still looking for an answer!

0 Kudos
norrierfc
1 Nickel

RE: Dell TB16 - Latitude 7370 various issues

Do you have citrix receiver installed on the laptop  ? What I eventually found out was that citrix receiver 4.3.1 (sometimes 14.3.100 it's called) was causing the issue , once I upgraded to the latest version then it worked fine and was stable

0 Kudos
jetshine
1 Copper

RE: Dell TB16 - Latitude 7370 various issues

Wow! Thanks norrierfc!  Yes, I had Citrix receiver installed... and after I completely uninstalled Citrix, I was able to successfully install the ASMedia drivers from Dell, and this time all the devices appear to be installed properly in device manager (no more mysterious Unknown Device), and the USB ports on the TB16 are working again.   And now that I have the proper ASMedia controller driver installed, it appears to be holding a stable connection to the dock.

This is not the first time I've had problems with Citrix receiver... I don't know why it seems to cause such mysterious interactions with actual hardware devices.

THANK you!!

0 Kudos
jphughan
5 Tungsten

RE: Dell TB16 - Latitude 7370 various issues

Interesting solution here!  For what it's worth, it looks like a new version of the ASMedia USB driver was released just today, citing compatibility improvements with the Win10 Creators Update, although there may of course be other fixes that Dell didn't bother to mention.

With the benefit of hindsight now that the culprit has been identified, I suppose it makes sense.  Citrix Receiver adds USB filter drivers to allow redirecting locally attached USB devices to the remote server hosting the application being streamed (e.g. to use a local headset with a remotely hosted IP softphone app), so I can definitely see how that could interfere with USB functionality.

Out of curiosity, have you tried installing Citrix Receiver now that you've gotten the ASMedia driver updated?  If so, is everything still stable or is it not possible to have Citrix Receiver and a stable dock connection at the same time?  Although if I'm reading the post marked as an answer correctly, it seems the new version of Citrix Receiver resolves this issue?  Unless that post was referring to updating to the latest version of the ASMedia driver?

0 Kudos
norrierfc
1 Nickel

RE: Dell TB16 - Latitude 7370 various issues

Hi

The issue is only specific to citrix receiver (1).4.3.100 , if you upgrade to a later version then it works fine

After I discovered this I went hunting on the Citrix website for the release notes for the next CR version up (4.5) and found a possible culprit, can't say for sure but it defintiely sounds like suspsciously similar

docs.citrix.com/.../4-5.html

•When using Citrix Receiver for Windows 4.3, devices connected through USB 3.0 - including keyboards and mouse devices - might stop working and show the error DRIVER_POWER_STATE_FAILURE (0x9f).

[#LC4542]

0 Kudos
jetshine
1 Copper

RE: Dell TB16 - Latitude 7370 various issues

Things appeared to be working again only after I uninstalled Citrix receiver, and then installed the ASMedia drivers (1.16.47.1).  I have not yet re-installed Citrix.  It looks like I had v.4.4.0.65534 installed previously, but I see now they have a version 4.9.

I see that Dell just released an updated ASMedia driver (v1.16.49.1), I think I'll try updating that first, and then try installing the newer Citrix receiver.  I will report back on how it goes.

0 Kudos
jetshine
1 Copper

RE: Dell TB16 - Latitude 7370 various issues

Little update after a week - even after successfully installing the ASMedia drivers, I'd still get the random TB16 disconnects, which is really annoying because it renders the system unusable for about 15 seconds, and when (if) it comes back, all the windows have resized / moved themselves.  For whatever reason, none of this would happen if I left the lid open a crack.

I came across another thread on dell community which suggested the junky Dell 1820A wireless adapter was the culprit:

http://en.community.dell.com/support-forums/laptop/f/3519/t/19674928?pi41097=1

So i decided to try installer a newer Intel 8260 Wifi card.  So far, this seems to have finally fixed my problems, I can now run dual 4K monitors connected to the TB16 with the lid closed.  It has not disconnected once over the last several hours.

These Intel 8260 / 8265 cards are about $20 on Amazon, and you get better wifi reception too.