Highlighted
Kevincrouch4
1 Copper

Dell Vostro 3450 Inexplicably fails after RAM upgrade

Alright, I upgraded the RAM in a Vostro 3450 laptop a couple of days ago. Went from one 2GB PC3-10600 stick to two 2x4GB PC3-10666 sticks. 

My process was as follows:

  • Shutdown, Unplug and remove battery
  • Hold power button for ~10 seconds to clear and extra power left in capacitors that I could
  • Remove memory door from back
  • Clip antistatic wrist clip so it was on metal, and grounded manually as well
  • remove old stick of RAM, place in antistatic bag
  • Blow out some dust from area ( I checked later to make sure none had lodged in the way of the connectors)
  • place in new RAM sticks, using fingers to push back retaining clips so that I wouldn't be pushing on it so hard
  • Boots up, I verify I see all the new RAM in BIOS
  • Boot up into windows, make sure windows sees all the new ram
  • Boot to and run memory diagnostic with no issues; good ram
  • Return computer to user

  • ...Two days later...

  • Now the computer does not boot. User claimed it didn't work the first time he tried it (I gave to him friday evening he tried using first monday morning and left it at work in the mean time) 
  • It cuts on, and then the lights (the three lights in the top right area of the keyboard) flash beginning with the left one.
    • Lights go (with one on at a time) Left, Center, Right,Center, computer off.
    • Normally (before I changed RAM and immediately after but before it was returned) they would go Left,center,right,center,left and then the screen would cut on.
  • I cannot boot, even to the BIOS. 
  • Made sure no USB media, expresscards, SD cards, CDs....
  • Tried reseating new RAM, no difference
  • blew out area again and visually inspected RAM and RAM connections, no issues
  • Tried booting strictly off AC power, wouldnt even try to turn on 
  • Inserted battery into laptop with AC adapter in, no indication of charging, but does try booting like mentioned above
  • Verified that Battery and charger both work individually and as a pair in another laptop of same model
  • Removed RAM and tried booting, received POST code of two beeps (translates to no RAM in the owners manual)
  • Visually inspected area around RAM slots, no apparent problems
  • Tried to smell for any smoke or blown/shorted electronics. No smells apparent
  • Put old RAM back in and tried booting, fails to boot like mentioned above 
  • Tried old and new RAM in another laptop of same model with no problems
  • Put new RAM back in laptop, removed battery and came here. 

I am out of ideas of what might be going on? The only thing I am left with is a motherboard problem that manifested more than an hour after installing the RAM and passing multiple checks and with no indicators that it was dropped or abused in a way that would cause a motherboard problem. 

As far as I can tell, it's getting past POST (because it knows there is RAM there) and failing before it can get to even loading the BIOS or doing anything with the screen. Did I screw up somehow? Based on what I know, this is a textbook RAM upgrade. Is there anything I missed? Thoughts, suggestions, ways to fix  the damn laptop? 

0 Kudos
4 Replies
Moderator
Moderator

RE: Dell Vostro 3450 Inexplicably fails after RAM upgrade

Hi Kevincrouch4,

 

Thanks for such a detailed post! I agree with your diagnosis in that this sounds like a motherboard failure, unfortunately timed very close to your upgrade. I would suggest before replacing parts though, that you attempt clearing the systems NVRAM / CMOS settings to see if this has any effect, if you have not already.

This could be performed by simply removing the systems CMOS battery and RAM, then holding the power button down to clear any residual power. After clearing reinstall the CMOS and memory and attempt to power up.

 

Hopefully the cause is merely NVRAM corruption and clearing will have you back up and running but let us know how it goes.

 

Thanks,

0 Kudos
Kevincrouch4
1 Copper

RE: Dell Vostro 3450 Inexplicably fails after RAM upgrade

Okay, I'm working on it now. Super annoying with this model. Have to go all the way down to removing the system board to remove the button cell battery then reassemble halfway to hit the power button just to disassemble it again to put a fresh battery (as long as I'm this far I'm replacing the sucker) to then reassemble it again and see if it helped. 

0 Kudos
zwer4e
1 Nickel

RE: Dell Vostro 3450 Inexplicably fails after RAM upgrade

while you are taking it apart, try booting with minimum components connected - leave memory in as you are getting the 2 beeps, disconnect keyboard, touchpad, media buttons, wifi card, speakers, etc, only leave motherboard, heatsink with fan, memory and power button(it is the left most cable on the palmrest). Remove the right hand side I/O board(the one with the wifi card) as well if it is still not booting.


If with minimum components it gets further than before it means something else is causing the issue and the memory swap is just a coincidence

I will personally bet on the right hand side IO board Smiley Happy

0 Kudos
Kevincrouch4
1 Copper

RE: Dell Vostro 3450 Inexplicably fails after RAM upgrade

Dell forum kept failing to post my update a few days ago and I got fed up. long story short, CMOS battery didn't help. I used a brand new replacement battery (I triple checked the battery type) and tried different HDDs while I had it open. 

I see someone has posted another suggestion of bad IO board, I'll test that this afternoon

0 Kudos