Ruhmon
1 Nickel

Dell XPS 13 2 in 1 - Freezing issues

I recently purchased a dell XPS 13 2 in 1 and it worked fine. I updated the latest version of all drivers from the Dell site and also updated windows 10.  Now the laptop intermittently freezes for 1-2 seconds often. This happens in general browing, typing and watching you tube videos.

I am not able to understand what is causing the issue as it worked fine before updating the drivers. Any help would be appreciated.

0 Kudos
22 Replies
Moderator
Moderator

RE: Dell XPS 13 2 in 1 - Freezing issues

Hi RUHMON,

What is the exact system model? Was the system freezing before you updated to Win 10 or did the issue start only after updating to Win 10?

Does this happen with or without the adapter connected?

Update the BIOS - http://dell.to/1n3X2po  - enter the service tag and download the BIOS, update and restart the machine and check.

Restart and check in safe mode with networking.

Enable the built in admin account and check. 

Restart the system and press f12 key on startup - choose diagnostics. Let it run the diags and if you encounter any errors - make a note of the complete error and report the same to us. These are onboard diagnostics and they might possible pick some error if the hardware is not functional. Also, run an extended / thorough tests on the HDD and memory to check for any possible errors. 

If the issue is unresolved, then restart the system and press f2 to enter BIOS - leave the system in BIOS with the adapter plugged in for as long as possible and check if the system freezes while in BIOS - you would notice there is a system clock ticking in BIOS - if the system freezes, then the clock would have frozen as well.

Also, please click my DELL-username and write me a private conversation with the service tag and your contact details(Name and Email) for case records.

Let us know if you have any other queries.

Thanks and Regards,
DELL-Rishi
Social Media and Communities Professional
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

0 Kudos
Ruhmon
1 Nickel

RE: Dell XPS 13 2 in 1 - Freezing issues

Thank you for the reply!

I had earlier updated the BIOS with the latest version and updated all other components of dell as well after which I started facing the problem.

I ran the diagnostics in f12 and all the tests passed.

I noticed that in BIOS also my mouse just hangs for a fraction of a second.

I reset my laptop and reinstalled windows but the same issue exists.

0 Kudos
Moderator
Moderator

RE: Dell XPS 13 2 in 1 - Freezing issues

Hi RUHMON,

Thank you for the update.

What is the exact system model?

When in BIOS, you have stated that "I noticed that in BIOS also my mouse just hangs for a fraction of a second." Did the system clock freeze in BIOS at that point and then resume?

Kindly confirm this, as it might be a hardware issue.

Also, please private message me the service tag, so I could check the warranty details.

Let us know if you have any other queries.

Thanks and Regards,
DELL-Rishi
Social Media and Communities Professional
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

0 Kudos
Ruhmon
1 Nickel

RE: Dell XPS 13 2 in 1 - Freezing issues

I can't see the clock in the bios. The mouse was hanging just for a fraction of a second.

I noticed that while playing youtube videos, for that fraction of a second the CPU is at 100% in task manager. It is just for a fraction of a second. This probably causes that freeze

Sometimes my web browser hangs for 1-2 seconds while loading the webpage.

I have DELL XPS 9365

0 Kudos
Saltgrass
4 Ruthenium

RE: Dell XPS 13 2 in 1 - Freezing issues

The only place I have really noticed a delay is when I do a two finger scroll.  It seems if I don't put the fingers down first, the scroll will delay a second or so.

There are many things running on these systems which take processing time.  From Anti-viruses to Waves audio polling the Audio plug for activity.  If it is really bad you may be able to see something jumping to the top of the CPU utilization column in Task Manager.

If Task Manager doesn't find anything you might go up to the Resource Monitor and if that doesn't help you could try Process Monitor from System Internals.

I would check for you but since I have not seen the problem you seem to have it would do no good.

I have updated my system with a higher quality M.2 PCIe SSD.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
Ruhmon
1 Nickel

RE: Dell XPS 13 2 in 1 - Freezing issues

Thanks for your reply.

It's very strange on my laptop, when running a youtube video , if I open another tab, the firefox browser takes more than 100% of the CPU and it hangs for 1-2 seconds. Same thing with chrome as well.

I don't recall this issue when I used the laptop out of the box and remember that this happened after I updated from dell and windows. Since I reset my laptop, I'm thinking it is one of the firmware updates that is causing this issue. Bios and Intel Chipset update.

0 Kudos
Moderator
Moderator

RE: Dell XPS 13 2 in 1 - Freezing issues

Hi RUHMON,

Thank you for the update.

If the system was working fine earlier, then perform a system restore to restore the machine to an earlier point where it was working fine - http://bit.ly/1JEw2ov 

Kindly test the system in safe mode with networking and the builtin admin account as advised in my previous post.

Let us know if you have any other queries.

Thanks and Regards,
DELL-Rishi
Social Media and Communities Professional
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

0 Kudos
Saltgrass
4 Ruthenium

RE: Dell XPS 13 2 in 1 - Freezing issues

If you are running Chrome, it eats up a lot of system memory .. you might want to check how yours is doing.  I do not know about Firefox.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
chiefchie
1 Copper

RE: Dell XPS 13 2 in 1 - Freezing issues

Ruhmon, I think I have the same issue and was able to find a solution.

When I go to Task Manager(ctrl+alt+del) then Performance, I'm only getting 0.3GHz of speed!

I disable SpeedSet BIOS (Reboot then F2 to access BIOS). In BIOS, click Performance tab and UNCHECK enable SpeedSet. It may reduce battery life to 1-2hours but increase speed dramatically! You can check back Task manager after disabling SpeedSet. My speed became 1.29GHz!! Hope this helps.