Highlighted
regretor
1 Copper

Dell XPS 13 2015

I have been using computers since the early 1990's. I have always had a poor impression of Dell products. This year I saw so many positive reviews of the Dell XPS 13 calling it "the best laptop of the year" and "the best laptop ever" that I decided to give it a chance.


I used it for two weeks to try it out and became comfortable with the machine. I then loaded it up with a lot of business files for an extended trip overseas. Because I am in a very underdeveloped area with poor infrastructure downloading large files or cloud computing isn't really possible.


Today when I turned on the computer and tried to check my email I got the blue screen of death which is something I haven't seen since Windows XP even though I use a computer every day of my life. The computer rebooted but after a long pause at the dell logo screen I got four lines of text:


"No bootable devices found.

"Press F1 key to retry boot.

"Press F2 key for setup utility.

"Press F5 key to run onboard diagnostics."

When I select F5 the test pauses at the hard drive and says "Hard Drive - Not Installed. Continue testing?"

When I go into bios with F2 no hard drive is found either. "MiniCard SSD Device = (none).

If I use the Windows 8.1 boot from USB and go into command prompt I don't find the hard drive.

The device was never dropped or anything like that. It simply worked then it didn't. I was receiving annoying Dell pop ups on a daily basis telling me I need to update. Early on I always clicked update and it worked and restarted. Lately the pop up would be unclickable and unclosable. Could this be an update or bios problem? Could the SSD on the expensive new piece of machinery have died?

As stated I'm in a very underdeveloped part of the world trying to do my work. Internet is slow. The time difference makes it card to call Dell tech support. Sending the laptop in to Dell is obviously impossible.

Any advice, or have I just wasted $1000 by finally giving in and giving a Dell product a chance?

0 Kudos