Highlighted

Dell XPS 13 9350 touchpad two finger scrolling "jumps"

Hi,

I have the brand new Dell XPS 13 9350 with Windows 10. When I use the touchpad with two fingers to scroll down on websites the content "jumps" back up some lines. This happens when lifting the fingers from the touchpad.

It occurs in Chrome and Edge and is pretty annoying because I'm losing focus on the page I'm reading everytime I use two finger scrolling.

Any idea how this can be fixed? I found no driver for touchpad on Dells support page for the XPS 13 and I'm not sure if I should use Synaptic drivers ...

Thanks in advance
Frank

Tags (3)
33 Replies
carl0
1 Nickel

RE: Dell XPS 13 9350 touchpad two finger scrolling "jumps"

I can also confirm problems with my brand new XPS13 which i received today.
For me the touchpad is, let's say, unresponsive.

If i start scrolling up or down with two fingers it needs 1-2 seconds of scrolling before it starts scrolling on the screen. This is VERY annoying!

I mean the scrolling on my 7 year old Sony Vaio was better than this....

How to fix it?! The problem appears in every program

carl0
1 Nickel

RE: Dell XPS 13 9350 touchpad two finger scrolling "jumps"

Okay  I already found the solution for my problem.

Activating "Reverse scrolling direction" in the Windows settings in "Devices -> Mouse / Touchpad" suddenly solved the problem.

The scrolling direction is now reversed which is totally ok for me and the problem with the delay in scrolling is gone now. Very weird, I hope this will help someone.

0 Kudos

RE: Dell XPS 13 9350 touchpad two finger scrolling "jumps"

I have already reversed scrolling, no solution unfortunately.

0 Kudos
carl0
1 Nickel

RE: Dell XPS 13 9350 touchpad two finger scrolling "jumps"

hey frank,

try to deactivate the 2 finger pinch to zoom option in the touchpad settings in windows, this should really help.

Tell us if something changed for you then

0 Kudos

RE: Dell XPS 13 9350 touchpad two finger scrolling "jumps"

Hi Carl,

I already disables two finger zoom but this does not solve the sxroll jumping problem. Do you have the same behavior?

0 Kudos
carl0
1 Nickel

RE: Dell XPS 13 9350 touchpad two finger scrolling "jumps"

Hey,

yes I also had this behaviour with Windows 10 in the chrome browser,

after reverting the direction it got better and after deactivating two finger pinch to zoom it went away completely.

In the Edge browser there was no problem.

This is indeed a very annoying issue but i think it is software related because I don't have any issues since I am running Ubuntu on my XPS 13

0 Kudos

RE: Dell XPS 13 9350 touchpad two finger scrolling "jumps"

I found a workaround: lifting one finger instead of two to stop scrolling works without jumps. But this is no final solution and still annoying.

Carl when you revert scrolling does it happen again or is it solved completely?

Iban
1 Copper

RE: Dell XPS 13 9350 touchpad two finger scrolling "jumps"

Hi,

I have a new XPS13 9350 and the touchpad has two problems:

  • There is a delay of about 5 millimeters from it begins to move the finger until the cursor moves.
  • The scrolling with two fingers is imprecise and unpredictable

The solution is to do a clean install of windows 10. However this solution is not simple because all data and programs installed will be deleted.

This is what we must do to perform clean installation of Windows 10 (ALL DATA AND PROGRAMS WILL BE DELETED!!!):

1) Create a installation USB stick using the tool by Microsoft (you need a empty USB stick): https://www.microsoft.com/en-us/software-download/windows10

2) If you have a SSD, download the driver for SSD from the Intel site (.zip format):

https://downloadcenter.intel.com/product/55005/Intel-Rapid-Storage-Technology-Intel-RST-

Download the driver "f6flpy-x64.zip". Create a folder in the root directory of the USB stick (Driver_SSD) and unzip the "f6flpy-x64.zip" file in it.

3) Download the driver for the WIFI card from the Dell site:

http://www.dell.com/support/home/us/en/19/product-support/product/xps-13-9350-laptop/drivers

Within the category "Network" download the driver "Dell Wireless 1820A WiFi Driver". Create a folder in the root directory of the USB stick (Driver_WIFI) and copy the file "9350_Network_Driver_MYJHH_WN32_1.519.0.0_A01.EXE" in it.

4) Boot the computer and press F12 to enter in the boot menu. Then choose the USB stick to boot from it.

5) Accept the license terms (the text and buttons are very small due to the screen resolution). Choose the custom installation (second option).

6) If you have a SSD, when the warning that there is no drive unit is displayed, press the button to load driver and go to the "Driver_SSD" USB folder to load the Intel RAID Controller.

7) Select the primary partition (which is larger) and within the advanced options remove it, remaining as unallocated space. Select the unallocated space and click "Next" to start the installation.

8) When installation is complete, after starting Windows 10, install the WIFI driver "9350_Network_Driver_MYJHH_WN32_1.519.0.0_A01.EXE" that had been copied to the "Driver_WIFI" folder on the USB.

9) Connect to the wireless network and let Windows update.

0 Kudos
aboniadi
1 Nickel

RE: Dell XPS 13 9350 touchpad two finger scrolling "jumps"

I have the same problem!!  Neither reverse scrolling nor the deactivating two finger zoom fixed the problem.  For a system that is otherwise flawless, it is quite absurd that my brand new XPS 13 is causing annoyance due to a touchpad issue.