mitsos1os
Bronze

Dell XPS 13 9360 USB ethernet (Dell adapter) not recognised after wake from suspend

I have the Dell XPS 13 9360 and have been using the Dell USB type-C adapter to connect to wired Ethernet network. I have a problem when waking up the laptop from suspend. VGA and USB on the adapter continue to work well after wake from suspend but the Wired Network functionality of the adapter is not recognized.

Note that if I unplug and replug the adapter it is recognised correctly.

The adapter is using the driver r8152 for wired networking, I am using Linux Mint 18.1 (Ubuntu 16.04 based) and kernel 4.8.0.34

Besides this I think almost everything works perfect with the laptop

I am also attaching the content of dmesg after I wake up from sleep:

[16815.124956] ACPI : EC: EC stopped
[16815.124958] PM: Saving platform NVS memory
[16815.125016] Disabling non-boot CPUs ...
[16815.126260] Broke affinity for irq 276
[16815.128484] smpboot: CPU 1 is now offline
[16815.146729] Broke affinity for irq 122
[16815.146806] Broke affinity for irq 276
[16815.146817] Broke affinity for irq 277
[16815.147934] smpboot: CPU 2 is now offline
[16815.174307] Broke affinity for irq 1
[16815.174317] Broke affinity for irq 8
[16815.174325] Broke affinity for irq 9
[16815.174334] Broke affinity for irq 12
[16815.174342] Broke affinity for irq 14
[16815.174351] Broke affinity for irq 16
[16815.174359] Broke affinity for irq 17
[16815.174370] Broke affinity for irq 51
[16815.174383] Broke affinity for irq 122
[16815.174434] Broke affinity for irq 276
[16815.174443] Broke affinity for irq 277
[16815.174452] Broke affinity for irq 279
[16815.174461] Broke affinity for irq 280
[16815.175552] smpboot: CPU 3 is now offline
[16815.193621] ACPI: Low-level resume complete
[16815.193736] ACPI : EC: EC started
[16815.193736] PM: Restoring platform NVS memory
[16815.194531] mce: [Hardware Error]: Machine check events logged
[16815.194582] Enabling non-boot CPUs ...
[16815.217226] x86: Booting SMP configuration:
[16815.217226] smpboot: Booting Node 0 Processor 1 APIC 0x2
[16815.219771] cache: parent cpu1 should not be sleeping
[16815.219967] CPU1 is up
[16815.261542] smpboot: Booting Node 0 Processor 2 APIC 0x1
[16815.264555] cache: parent cpu2 should not be sleeping
[16815.265042] CPU2 is up
[16815.293753] smpboot: Booting Node 0 Processor 3 APIC 0x3
[16815.296732] cache: parent cpu3 should not be sleeping
[16815.297398] CPU3 is up
[16815.305150] ACPI: Waking up from system sleep state S3
[16816.340815] acpi LNXPOWER:13: Turning OFF
[16816.340988] acpi LNXPOWER:12: Turning OFF
[16816.341158] acpi LNXPOWER:11: Turning OFF
[16816.341327] acpi LNXPOWER:10: Turning OFF
[16816.341497] acpi LNXPOWER:0f: Turning OFF
[16816.341666] acpi LNXPOWER:0e: Turning OFF
[16816.341835] acpi LNXPOWER:0d: Turning OFF
[16816.342026] acpi LNXPOWER:0c: Turning OFF
[16816.342204] acpi LNXPOWER:0b: Turning OFF
[16816.342374] acpi LNXPOWER:0a: Turning OFF
[16816.342544] acpi LNXPOWER:09: Turning OFF
[16816.342713] acpi LNXPOWER:08: Turning OFF
[16816.342882] acpi LNXPOWER:07: Turning OFF
[16816.343052] acpi LNXPOWER:06: Turning OFF
[16816.343222] acpi LNXPOWER:05: Turning OFF
[16816.343393] acpi LNXPOWER:04: Turning OFF
[16816.343562] acpi LNXPOWER:03: Turning OFF
[16816.343731] acpi LNXPOWER:02: Turning OFF
[16816.343899] acpi LNXPOWER:01: Turning OFF
[16816.344069] acpi LNXPOWER:00: Turning OFF
[16816.422551] pcieport 0000:02:02.0: System wakeup disabled by ACPI
[16816.527041] xhci_hcd 0000:00:14.0: System wakeup disabled by ACPI
[16816.527199] PM: noirq resume of devices complete after 182.233 msecs
[16816.574383] PM: early resume of devices complete after 46.720 msecs
[16816.575320] usb usb3: root hub lost power or was reset
[16816.575321] usb usb4: root hub lost power or was reset
[16816.575528] sd 2:0:0:0: [sda] Starting disk
[16816.576336] rtc_cmos 00:01: System wakeup disabled by ACPI
[16816.596148] [drm] GuC firmware load skipped
[16816.856690] usb 1-5: reset high-speed USB device number 3 using xhci_hcd
[16816.892621] ata3: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[16816.896208] ata3.00: configured for UDMA/133
[16818.058213] [drm] RC6 on
[16822.011408] xhci_hcd 0000:39:00.0: Timeout while waiting for setup device command
[16827.411265] xhci_hcd 0000:39:00.0: Timeout while waiting for setup device command
[16827.620170] usb 4-1: device not accepting address 4, error -62
[16827.800914] usb 3-1: reset high-speed USB device number 5 using xhci_hcd
[16828.435922] usb 3-1.1: reset low-speed USB device number 6 using xhci_hcd
[16828.805536] usb 3-1.3: reset full-speed USB device number 7 using xhci_hcd
[16828.909936] PM: resume of devices complete after 12281.010 msecs
[16828.911067] PM: Finishing wakeup.
[16828.911070] Restarting tasks ...
[16828.911876] pci_bus 0000:02: Allocating resources
[16828.911972] pcieport 0000:02:01.0: bridge window [io 0x1000-0x0fff] to [bus 04-38] add_size 1000
[16828.911997] pcieport 0000:02:02.0: bridge window [io 0x1000-0x0fff] to [bus 39] add_size 1000
[16828.912006] pcieport 0000:02:02.0: bridge window [mem 0x00100000-0x000fffff 64bit pref] to [bus 39] add_size 200000 add_align 100000
[16828.912030] pcieport 0000:02:01.0: res[13]=[io 0x1000-0x0fff] res_to_dev_res add_size 1000 min_align 1000
[16828.912037] pcieport 0000:02:02.0: res[13]=[io 0x1000-0x0fff] res_to_dev_res add_size 1000 min_align 1000
[16828.912043] pcieport 0000:01:00.0: bridge window [io 0x1000-0x0fff] to [bus 02-39] add_size 2000
[16828.912052] pcieport 0000:01:00.0: res[13]=[io 0x1000-0x0fff] res_to_dev_res add_size 2000 min_align 1000
[16828.912058] pcieport 0000:01:00.0: res[13]=[io 0x1000-0x2fff] res_to_dev_res add_size 2000 min_align 1000
[16828.912068] pcieport 0000:01:00.0: BAR 13: no space for [io size 0x2000]
[16828.912073] pcieport 0000:01:00.0: BAR 13: failed to assign [io size 0x2000]
[16828.912080] pcieport 0000:01:00.0: BAR 13: no space for [io size 0x2000]
[16828.912085] pcieport 0000:01:00.0: BAR 13: failed to assign [io size 0x2000]
[16828.912100] pcieport 0000:02:02.0: res[15]=[mem 0x00100000-0x000fffff 64bit pref] res_to_dev_res add_size 200000 min_align 100000
[16828.912106] pcieport 0000:02:02.0: res[15]=[mem 0x00100000-0x002fffff 64bit pref] res_to_dev_res add_size 200000 min_align 100000
[16828.912112] pcieport 0000:02:01.0: res[13]=[io 0x1000-0x0fff] res_to_dev_res add_size 1000 min_align 1000
[16828.912118] pcieport 0000:02:01.0: res[13]=[io 0x1000-0x1fff] res_to_dev_res add_size 1000 min_align 1000
[16828.912123] pcieport 0000:02:02.0: res[13]=[io 0x1000-0x0fff] res_to_dev_res add_size 1000 min_align 1000
[16828.912129] pcieport 0000:02:02.0: res[13]=[io 0x1000-0x1fff] res_to_dev_res add_size 1000 min_align 1000
[16828.912144] pcieport 0000:02:02.0: BAR 15: no space for [mem size 0x00200000 64bit pref]
[16828.912149] pcieport 0000:02:02.0: BAR 15: failed to assign [mem size 0x00200000 64bit pref]
[16828.912155] pcieport 0000:02:01.0: BAR 13: no space for [io size 0x1000]
[16828.912159] pcieport 0000:02:01.0: BAR 13: failed to assign [io size 0x1000]
[16828.912164] pcieport 0000:02:02.0: BAR 13: no space for [io size 0x1000]
[16828.912168] pcieport 0000:02:02.0: BAR 13: failed to assign [io size 0x1000]
[16828.912181] pcieport 0000:02:02.0: BAR 15: no space for [mem size 0x00200000 64bit pref]
[16828.912186] pcieport 0000:02:02.0: BAR 15: failed to assign [mem size 0x00200000 64bit pref]
[16828.912191] pcieport 0000:02:02.0: BAR 13: no space for [io size 0x1000]
[16828.912195] pcieport 0000:02:02.0: BAR 13: failed to assign [io size 0x1000]
[16828.912200] pcieport 0000:02:01.0: BAR 13: no space for [io size 0x1000]
[16828.912205] pcieport 0000:02:01.0: BAR 13: failed to assign [io size 0x1000]
[16828.915326] pci_bus 0000:02: Allocating resources
[16828.915419] pcieport 0000:02:01.0: bridge window [io 0x1000-0x0fff] to [bus 04-38] add_size 1000
[16828.915449] pcieport 0000:02:02.0: bridge window [io 0x1000-0x0fff] to [bus 39] add_size 1000
[16828.915461] pcieport 0000:02:02.0: bridge window [mem 0x00100000-0x000fffff 64bit pref] to [bus 39] add_size 200000 add_align 100000
[16828.915490] pcieport 0000:02:01.0: res[13]=[io 0x1000-0x0fff] res_to_dev_res add_size 1000 min_align 1000
[16828.915500] pcieport 0000:02:02.0: res[13]=[io 0x1000-0x0fff] res_to_dev_res add_size 1000 min_align 1000
[16828.915509] pcieport 0000:01:00.0: bridge window [io 0x1000-0x0fff] to [bus 02-39] add_size 2000
[16828.915520] pcieport 0000:01:00.0: res[13]=[io 0x1000-0x0fff] res_to_dev_res add_size 2000 min_align 1000
[16828.915529] pcieport 0000:01:00.0: res[13]=[io 0x1000-0x2fff] res_to_dev_res add_size 2000 min_align 1000
[16828.915541] pcieport 0000:01:00.0: BAR 13: no space for [io size 0x2000]
[16828.915563] pcieport 0000:01:00.0: BAR 13: failed to assign [io size 0x2000]
[16828.915565] pcieport 0000:01:00.0: BAR 13: no space for [io size 0x2000]
[16828.915566] pcieport 0000:01:00.0: BAR 13: failed to assign [io size 0x2000]
[16828.915570] pcieport 0000:02:02.0: res[15]=[mem 0x00100000-0x000fffff 64bit pref] res_to_dev_res add_size 200000 min_align 100000
[16828.915572] pcieport 0000:02:02.0: res[15]=[mem 0x00100000-0x002fffff 64bit pref] res_to_dev_res add_size 200000 min_align 100000
[16828.915574] pcieport 0000:02:01.0: res[13]=[io 0x1000-0x0fff] res_to_dev_res add_size 1000 min_align 1000
[16828.915575] pcieport 0000:02:01.0: res[13]=[io 0x1000-0x1fff] res_to_dev_res add_size 1000 min_align 1000
[16828.915577] pcieport 0000:02:02.0: res[13]=[io 0x1000-0x0fff] res_to_dev_res add_size 1000 min_align 1000
[16828.915578] pcieport 0000:02:02.0: res[13]=[io 0x1000-0x1fff] res_to_dev_res add_size 1000 min_align 1000
[16828.915583] pcieport 0000:02:02.0: BAR 15: no space for [mem size 0x00200000 64bit pref]
[16828.915584] pcieport 0000:02:02.0: BAR 15: failed to assign [mem size 0x00200000 64bit pref]
[16828.915586] pcieport 0000:02:01.0: BAR 13: no space for [io size 0x1000]
[16828.915587] pcieport 0000:02:01.0: BAR 13: failed to assign [io size 0x1000]
[16828.915589] pcieport 0000:02:02.0: BAR 13: no space for [io size 0x1000]
[16828.915590] pcieport 0000:02:02.0: BAR 13: failed to assign [io size 0x1000]
[16828.915594] pcieport 0000:02:02.0: BAR 15: no space for [mem size 0x00200000 64bit pref]
[16828.915595] pcieport 0000:02:02.0: BAR 15: failed to assign [mem size 0x00200000 64bit pref]
[16828.915597] pcieport 0000:02:02.0: BAR 13: no space for [io size 0x1000]
[16828.915598] pcieport 0000:02:02.0: BAR 13: failed to assign [io size 0x1000]
[16828.915600] pcieport 0000:02:01.0: BAR 13: no space for [io size 0x1000]
[16828.915601] pcieport 0000:02:01.0: BAR 13: failed to assign [io size 0x1000]
[16828.926006] usb 4-1: USB disconnect, device number 4
[16828.926010] usb 4-1.4: USB disconnect, device number 5
[16828.956089] done.

0 Kudos
4 Replies
Community Manager
Community Manager

RE: Dell XPS 13 9360 USB ethernet (Dell adapter) not recognised after wake from suspend

Hi mitos1os,

Thanks for posting.

Here is some information you may find helpful:

http://dell.to/2k7yXox


Dell-Robert P
Social Media Support
#IWork4Dell
To help us troubleshoot, please send us the Dell service tag number via a private message
Would you like to be a Dell Community Rockstar?


0 Kudos
vosaxalo
Copper

RE: Dell XPS 13 9360 USB ethernet (Dell adapter) not recognised after wake from suspend

Hi,

after the recent update of the network manager package on Ubuntu, from the version 1.22 to the version 1.26, I have big problems with the ethernet connection. Every time after Suspend, the cable connection is not working anymore. I mean, the network manager applet shows that the connection is alive, but with the browser I can't navigate. On every page there is a problem of DNS or proxy, that it's clearly wrong.

If I use the command:

service network-manager restart

sometimes the connection works again, but after a couple of Suspend the only solution is to reboot the PC.

0 Kudos
anonymous25
Copper

RE: Dell XPS 13 9360 USB ethernet (Dell adapter) not recognised after wake from suspend

hi @mitsos1os. It seems that I have a problem very similar to yours. I would need to get XPS 13 9360 to wake up on a wired Ethernet connected through a USB-C adapter. I am using Ubuntu 17.10.

Were you able to get your system working after all? I'd appreciate any clues.

0 Kudos
mitsos1os
Bronze

RE: Dell XPS 13 9360 USB ethernet (Dell adapter) not recognised after wake from suspend

Hi there, I do no think this is related to my problem... Mine was that the network did not revive after a suspend and yours is to keep it active while suspend in order to wake up... So I cannot help you with this... However my problem was resolved in later kernel updates... do not remember exactly the number, but surely on 4.10+

0 Kudos