Highlighted
caseykelso
1 Copper

Dell XPS 13 9365 - Won't boot USB in SATA Mode AHCI - Trying to install Ubuntu

Jump to solution

I have a brand new XPS 13 9365, It boots find to windows but I'm having difficulty installing Linux.

1) Secure boot is disabled

2) The laptop will boot to the Ubuntu installer on a USB drive when in SATA-RAID mode, but Linux cannot see the SSD in RAID mode.

3) The laptop hangs on boot and will not boot the USB drive when in SATA-AHCI mode, I have verified the boot order. Also when in AHCI mode it takes over 5 minutes to get into the BIOS menu.

I'm running the latest 1.0.5 bios.

Is this a bug in the BIOS similar to what was seen with AHCI on the 9360 last year?

Please provide feedback on how the Developer Edition of the 9365 is configured.


Thanks

Casey

0 Kudos
39 Replies
Saltgrass
4 Ruthenium

RE: Dell XPS 13 9365 - Won't boot USB in SATA Mode AHCI - Trying to install Ubuntu

Jump to solution

Why did you disable Secure Boot?  Be very careful with Linux and do research prior to even trying..

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
caseykelso
1 Copper

RE: Dell XPS 13 9365 - Won't boot USB in SATA Mode AHCI - Trying to install Ubuntu

Jump to solution

The OS image needs to be signed with Dell's keys or a managed set of keys stored in the BIOS else the trustzone will be violated and the device won't boot a 3rd party OS, ex. Linux. Disabling secure boot allows Linux to boot without being signed with the keys.

Has anyone had success at booting to a thumb drive with SATA set to AHCI?

0 Kudos
9 Rhodium

RE: Dell XPS 13 9365 - Won't boot USB in SATA Mode AHCI - Trying to install Ubuntu

Jump to solution

Do you in fact have a SATA SSD (128G) or is the drive NVMe (256G or larger)?

0 Kudos
caseykelso
1 Copper

RE: Dell XPS 13 9365 - Won't boot USB in SATA Mode AHCI - Trying to install Ubuntu

Jump to solution

Nvme 500gb

0 Kudos
J-b-m
1 Nickel

RE: Dell XPS 13 9365 - Won't boot USB in SATA Mode AHCI - Trying to install Ubuntu

Jump to solution

I have exactly the same problem, 500gb drive on a 9365. Changed the ATA mode from raid to ahci , now boot is extremely slow, it takes 5 minutes to reach the bios, and it is impossible to boot any drive.

0 Kudos
J-b-m
1 Nickel

RE: Dell XPS 13 9365 - Won't boot USB in SATA Mode AHCI - Trying to install Ubuntu

Jump to solution

This looks a lot like this recent xps 13 9360 bios issue:

en.community.dell.com/.../20000243

Should I open a support request?

0 Kudos
Saltgrass
4 Ruthenium

RE: Dell XPS 13 9365 - Won't boot USB in SATA Mode AHCI - Trying to install Ubuntu

Jump to solution

I have a Samsung 960 Pro on my 9365 with ONLY the NVMe drive, no other SATA drives.  I am not running Linux but SATA mode is disabled.

If you are doing a clean install of Linux by itself on that system you might try it.  If you currently have a Windows install and the drive is not running as NVMe or other drives configured for SATA, of course disabling SATA would cause that install problems.  

SATA being set to AHCI  should also make the drive available, assuming your are installing in UEFI mode.  Ubuntu is both UEFI and Secure Boot compatible.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
caseykelso
1 Copper

RE: Dell XPS 13 9365 - Won't boot USB in SATA Mode AHCI - Trying to install Ubuntu

Jump to solution

I spent much time on the phone with DELL support. Eventually DELL responded that AHCI is not supported with the M2.NVME drive and to return the laptop. I suspect that this feature isn't implemented on the 9365 as of yet, it was supported on the 9360. Maybe the BIOS team wil release a new version at some point with AHCI support for M2.NVME. In the meantime I'm switching to a different laptop.

This might be worth a try:

wiki.debian.org/.../SataRaid

0 Kudos
Saltgrass
4 Ruthenium

RE: Dell XPS 13 9365 - Won't boot USB in SATA Mode AHCI - Trying to install Ubuntu

Jump to solution

The reason Dell claims the system does not support AHCI is because the unit was shipped, as mine was, with the NVMe drive being controlled by the SATA controller which requires SATA be set to RAID.

My system had a Toshiba drive, but I suspect recent Bios updates have updated the NVMe driver in the Bios and is causing problems for systems with older drives, such as the SM951, and Secure Boot.

I am running the 1.00.05 version of the Bios.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos