Shiver87
1 Copper

Dell XPS 14z - Win 10 - Eject button not working

Hello,

I've upgraded my Dell XPS14z to Windows 10. After a clean install my eject button at the keyboard isnt working anymore. I can't find a solution. Is there someone who can help?

Regards,

Rob

0 Kudos
1 Reply
Moderator
Moderator

RE: Dell XPS 14z - Win 10 - Eject button not working

Hi Rob,

Is the ODD detected in Windows Explorer?

Does it show up in device manager? Is there an "!" mark or unknown devices?

Restart the system and press f2 key on startup to enter BIOS - check if the ODD ejects while in BIOS.

Update the BIOS - http://dell.to/1n3X2po - enter the service tag and download the BIOS, update and restart the machine and check.

Also, from the same site, check if there is any ODD firmware available for your specific ODD model listed under the tag.

If the ODD does not show up in Windows Explorer - try this - http://bit.ly/2jSg19X

Restart the system and press f12 key on startup - choose diagnostics. Let it run the diags and if you encounter any errors - make a note of the complete error and report the same to us. These are onboard diagnostics and they might possible pick some error if the hardware is not functional.

Also, please click my DELL-username and write me a private message with the service tag and your Name for case records.

Let us know if you have any other queries.

Thanks and Regards,
DELL-Rishi
Social Media and Communities Professional
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

0 Kudos