Burtandernie
1 Nickel

RE: Dell XPS 15 (9550) w/ Intel 530 / NVIDIA 960M - Intel Causing Screen Flickering

Jump to solution

Last try

0 Kudos
Burtandernie
1 Nickel

RE: Dell XPS 15 (9550) w/ Intel 530 / NVIDIA 960M - Intel Causing Screen Flickering

Jump to solution

So heres a little follow up.  After talking to dell for hours and hours they are sending me out a usb with windows 10 and their drivers.  I tried the creation tool method but I discovered you have to install certain drivers and change somethings around for it to format and properly install.  Its to much of a pain to deal with.  Dell has said the plug in usb will fix all of my issues.  They also stated it is as simple as plugging it in and going through the reinstall/formating.  Since i have messed around with so many things on this computer i hope it fixes whatever other problems i may have created.  I will recieve the usb in a few days.  Once i install it i will post my experience.  

0 Kudos
paperboat
1 Copper

RE: Dell XPS 15 (9550) w/ Intel 530 / NVIDIA 960M - Intel Causing Screen Flickering

Jump to solution

That is exactly what happens. Nothing works to fix it, I'm getting a Dell technician in soon, but I am 90% sure it's not a hardware problem.

0 Kudos
Burtandernie
1 Nickel

RE: Dell XPS 15 (9550) w/ Intel 530 / NVIDIA 960M - Intel Causing Screen Flickering

Jump to solution

Oh I am 99 percent sure its not hardware.  Its definitely a windows issue.  

0 Kudos
Moderator
Moderator

RE: Dell XPS 15 (9550) w/ Intel 530 / NVIDIA 960M - Intel Causing Screen Flickering

Jump to solution

I'm getting this issue escalated within Dell so that we can hopefully find a fix for the issue.

If possible can you try disabling C- States, Speed Step and Turbo Boost in the BIOS and check to see if the flickering persists or stops

Thanks

Colin H
Dell | Social Outreach Services

I'm based in the UK and available Monday to Friday 9am-5pm GMT

0 Kudos
devans3928
1 Nickel

RE: Dell XPS 15 (9550) w/ Intel 530 / NVIDIA 960M - Intel Causing Screen Flickering

Jump to solution

There could be multiple causes of the flicker.

I can verify that with my Win 10 Pro XPS 9550 that the flicker started when I installed hyper-v and goes away when I uninstall it. I updated to the latest Intel 4300 driver (15.40.10.4300) for the Intel HD 530 and the problem persists... so the only solution I have is to leave hyper-v uninstalled until there is an updated driver.

The same issue with the hyper-v has been reported against the Intel HD 520 graphics in Microsoft's Surface Book and other devices. These are both Intel Skylake integrated graphics so probably the same issue exists in both version.

0 Kudos
Burtandernie
1 Nickel

RE: Dell XPS 15 (9550) w/ Intel 530 / NVIDIA 960M - Intel Causing Screen Flickering

Jump to solution

Not sure if i want to do that before i get my usb.  However how would i go about doing that and how would I turn each one back on?

0 Kudos
Burtandernie
1 Nickel

RE: Dell XPS 15 (9550) w/ Intel 530 / NVIDIA 960M - Intel Causing Screen Flickering

Jump to solution

Yea that seems to work for some with windows pro.  Since the problem occurs on windows home which does not include hyper-v I am hoping they figure out the real cause of it.

0 Kudos
Burtandernie
1 Nickel

RE: Dell XPS 15 (9550) w/ Intel 530 / NVIDIA 960M - Intel Causing Screen Flickering

Jump to solution

Another issue that almost everyone is the cpu is not performing to spec.  Its greatly under performing.

0 Kudos
Moderator
Moderator

RE: Dell XPS 15 (9550) w/ Intel 530 / NVIDIA 960M - Intel Causing Screen Flickering

Jump to solution

Not sure if i want to do that before i get my usb.  However how would i go about doing that and how would I turn each one back on?

If yourself or anyone wants to disable Speedstep, C State or TurboBoost then do the following

1. Enter the BIOS (Press F2 when you see the Dell logo on Startup

2. Within the BIOS there is menu on the left hand side. Look for the "Performance" Entry and expand it

3. Click on Intel Speedstep - on the right hand side the details for the entry will be shown. Click in the box to disable Speedstep.

4. Repeat Step 3 for C States and Turboboost

5. Exit and Save Settings

6. Check if the issue has changed or stayed the same

To enable the 3 options repeat steps 1 and 2 above then

1. Click on Intel Speedstep - on the right hand side the details for the entry will be shown. Click in the box so that the tick is shown. This will enable Speedstep.

2. Repeat Step 1 for C States and Turboboost

3. Exit and Save Settings

Colin H
Dell | Social Outreach Services

I'm based in the UK and available Monday to Friday 9am-5pm GMT

0 Kudos