Highlighted
lusman
1 Copper

Dell XPS 15-9550 with External Monitor HP2311xi - keep getting blank screen on and off -

Bought DELL XPS 15-9550 with intel Core i7, 16G RAM, 1TB SSD HD, with Nvidia-GeForce GTX 960M from Best Buy last November.

Connected to external monitor HP2311xi through the HDMI.

Issue:

Everytime need to set up display as 2 display, HP as Main and laptop as extended. Then every 5 to 6 min, the system reverted back to single display by first blanking the screens.

Reset the display by clicking detect and the laptop screen come back alive, and then after 5 to 6 same thing happened

Talk to Geek Squad. Change the cable, update the Intel HD graphics drive, reinstall and uninstall. Still happening

Update BIOS to the latest available still not solve the issue

Even after letting it in single display mode, the blanking keep continue. It is very annoying and distracting while working.

Any one encounter the same issue.  Please share the resolution

Thank you

Tags (3)
0 Kudos
5 Replies
drhaen
1 Copper

RE: Dell XPS 15-9550 with External Monitor HP2311xi - keep getting blank screen on and off -

I am having the same issue with my XPS 15-9550 with Nvidia combined graphics connected to a Dell UP3216Q external monitor.

Typically when interacting with apps, i.e. scrolling in MS Edge browser, the external monitor blacks out for a few seconds. It is very intermittent, and tends to occur several times within a 30 second period then it will stop for a while. Acts like bad HDMI cable connection. I have the same issue with multiple cables, although it could be the receiving connector on either the laptop or the monitor.

Have changed drivers on both the Nvida and intel adapters with no change in behavior. Changed resolution, frame rate, etc.

The problem renders the system unusealbe and I will have to return both the laptop and display if not resolved soon.

0 Kudos
Jack Lin
1 Copper

RE: Dell XPS 15-9550 with External Monitor HP2311xi - keep getting blank screen on and off -

I am having the same exact problem.  Connecting to a Samsung 2560x1440 monitor via HDMI cable.  Sometimes it would just start blacking on and off, on and off.  It's driving me nuts.

I updated BIOS, Intel HD 530 drivers, nVidia 960M drivers.  Nothing helped...  Please fix this...

0 Kudos
yaret
1 Copper

RE: Dell XPS 15-9550 with External Monitor HP2311xi - keep getting blank screen on and off -

Same problem here!!!

When connecting to another monitor through HDMI, I can see that it recognizes it, but the monitor doesn't show anything.

After trying to solve by reinstalling and installing any possible driver, the problem persist.

THe only temp solution I found is when I change the external monitor resolution from the preferred, to the lowest possible.....it suddenly working properly. But if you unplug the cable and plug in it again...then the black screen comes back..

This issue is common to many people...HEY DELL, please a little bit of attention is needed here!

thank you very much! 

0 Kudos
AKB1
1 Copper

RE: Dell XPS 15-9550 with External Monitor HP2311xi - keep getting blank screen on and off -

Same Problem here, and also icon size on external monitor.

When connecting an external monitor (HP 1080 or Acer 1080) the screen blanks out every few minutes for at least 3-5 seconds.

Additionally, I have problems getting a reasonable icon size on the external monitor (connected through HDMI).  LIke others I have updated all the drivers, changed cables, changed monitors.

There doesn't seem to be a way to set the font/icon scaling separately for each monitor.  The xps monitor defaults to 250% scaling, and seems to apply this to an external monitor -- even though it says the monitor is at 100% scaling. 

I'm 10 days away from a week of meetings using this laptop to run presentation though a projector, and no solution in site.  Could be a disaster.  Considering returning this laptop and buying another brand.

0 Kudos
gnomik
1 Copper

RE: Dell XPS 15-9550 with External Monitor HP2311xi - keep getting blank screen on and off -

*** all! I went through all of these issues and after the latest windows updates my system got stacked and I had to turn it off to restart. After booting up I've realized that now I'm missing NVidia GeForce GTX 960M. I've tried to reinstall all kind of driver and recover my system, nothing helps. So looks like something really broken with these laptops. Now I will have to rebuild and reinstall whole OS 😞

0 Kudos