Highlighted
MarkVincze2
1 Copper

Dell XPS 15 9550 with Windows 10: HDMI not working (but Thunderbolt does)

I'm trying to use the Dell XPS 15 9550 with Windows 10, and I connected two external monitors, one to HDMI, one to Thunderbolt.

Only the one connected to Thunderbolt works, the other doesn't, it simply says no signal.

The cables and the port itself definitely work, if I switch to Ubuntu, both screens work.

On Windows, only the Thunderbolt works, even if I connect only one screen, the HDMI output doesn't work. I tried all combination of screens and cables, and in all combinations it is always the Thunderbolt output that works.

I'm on the latest updates with Windows 10. Latest NVidia drivers. Tried the latest Intel graphics drivers from the Dell site, also the latest ones from the Intel site.

One extra information: some forums suggested checking the NVidia Control Panel, but there I only have the "3D Settings" node in the tree, nothing else.

(I've googled a lot and read all the forum threads I could find, but nothing worked.)

1 Reply
Moderator
Moderator

RE: Dell XPS 15 9550 with Windows 10: HDMI not working (but Thunderbolt does)

Hi Mark,


Welcome to our community.


We can confirm this is a software issue and not hardware.


We’d suggest you to uninstall the video drivers completely. Alternatively, you can also contact our software support. Let us know the region you are located in, so that we can provide you with the right contact information. Please note- the service will be charged.

0 Kudos