Laptops General - Read Only

2 Bronze

Disable touchpad on XPS 17

When I have an USB mouse attached to my XPS 17 and type on the internal keyboard, I often touch the touchpad which places the cursor somewhere else on the screen.

This is quite annoying and would be solved if I could disable the touchpad.

Sadly, I can't find a place to disable the touchpad.

Any ideas?

Regards,

Rob

Replies (21)
2 Bronze

I followed your instructions but the Disable box in my PS/2 Driver window is grayed out. Now what?

2 Bronze

The "Disable" tab is faded and unclickable.  What now?  This is typical actually.  Figures.

Top Contributor
Latest Solutions