Laptops General - Read Only

Last reply by 08-16-2012 Solved
Start a Discussion
2 Bronze
2 Bronze
238413

Disabling IDT audio driver filters

Hi

We are using a DELL Vostro as a monitor for a medical device.

The audio driver applies some filters on the signals that we want to disable.

I've tried disabling all parameters in the IDT configuration utility, but still there are some noise cancelling and other filters that apply, that affect our received signal.

Is there a way to disable all audio filters?

Thank you for your help,

Guy 

Solutions (2)

Accepted Solutions
7 Plutonium
3000

Hello. I'm not sure what kind of filtering. Try disabling All Enhancements on the Enhancements tab found in the Speaker/Headphone properties of the Sound properties.

Also check if eq is enabled and disable it. If you still get filtering remove the IDT driver and its files and Windows will install its native (Intel) HD audio driver and see if that one is better for your purposes. A couple of ways to do this:

> Go to Device Manager and uninstall the IDT driver and select the option to delete the files. When done, reboot.

> Go to Start>Control Panel>Uninstall a Program. Find the audio driver then right click on it and uninstall it. When you reboot the computer Windows will install its native audio driver. Check that it is installed by going to the Sounds properties. If it says "High Definition Audio Device" on any of the tabs then it is the native driver. If it says "IDT High Definition Audio Codec" then it is still an IDT driver, so repeat the procedure. (Windows will keep installing IDT drivers until all that have been downloaded are removed.)

Jim Coates -- 18 years on the Dell Laptop Audio boards -- since 2/6/04 

View solution in original post

2 Bronze
2 Bronze
3000

Jim,

Thank you, i was able to solve the issue.

I uninstalled IDT, but that helped but did not solve the problem.

what eventually helped was to uninstall Advanced Audio FX Engine. turns out Advanced Audio FX Engine applies sound filters as well, and removing it finally did the job.

Now we are getting a clear and unfiltered signal.

Thanks a lot

Guy

View solution in original post

Replies (3)
7 Plutonium
3001

Hello. I'm not sure what kind of filtering. Try disabling All Enhancements on the Enhancements tab found in the Speaker/Headphone properties of the Sound properties.

Also check if eq is enabled and disable it. If you still get filtering remove the IDT driver and its files and Windows will install its native (Intel) HD audio driver and see if that one is better for your purposes. A couple of ways to do this:

> Go to Device Manager and uninstall the IDT driver and select the option to delete the files. When done, reboot.

> Go to Start>Control Panel>Uninstall a Program. Find the audio driver then right click on it and uninstall it. When you reboot the computer Windows will install its native audio driver. Check that it is installed by going to the Sounds properties. If it says "High Definition Audio Device" on any of the tabs then it is the native driver. If it says "IDT High Definition Audio Codec" then it is still an IDT driver, so repeat the procedure. (Windows will keep installing IDT drivers until all that have been downloaded are removed.)

Jim Coates -- 18 years on the Dell Laptop Audio boards -- since 2/6/04 

2 Bronze
2 Bronze
3001

Jim,

Thank you, i was able to solve the issue.

I uninstalled IDT, but that helped but did not solve the problem.

what eventually helped was to uninstall Advanced Audio FX Engine. turns out Advanced Audio FX Engine applies sound filters as well, and removing it finally did the job.

Now we are getting a clear and unfiltered signal.

Thanks a lot

Guy

7 Plutonium
3000

That's good.  Advanced Audio FX Engine is part of the webcam software, not the audio driver.

Jim Coates -- 18 years on the Dell Laptop Audio boards -- since 2/6/04 

Latest Solutions
Top Contributor