Gerald McFry
1 Copper

E1505 Doesn't "see" brand new SATA HD

I am working on a Inspiron E1505 Laptop and it doesn't "see" the SATA Hard Drive.  I have tried to load Windows XP onto it using a disk that supposedly has SATA drivers on it, but when it comes to finding the partition or drive to install it on, it doesn't find one.  The drive is a brand new Western Digital 250 gig drive.  It displays "No bootable devices; strike F1 to retry or F2 to go into setup..."   There is no place in the BIOS to change SATA settings.  I even put the drive in an HP laptop, loaded Windows XP on it and it still gives me the same message.  This thing is driving me crazy!  I am A+ Certified and have worked on PCs for more than 10 years and never run up against something like this.  Does anyone have any idea how to get it to recognize the hard drive?  Maybe flash the BIOS or something???  It is just 6 months out of warranty and I can't get into a chat session with technical support!  HELP!!!!

0 Kudos
6 Replies
husky0894
4 Beryllium

Re: E1505 Doesn't "see" brand new SATA HD

Does the BIOS see the drive?  If it doesn't,check the physical connection - there is usually an interposer board behind the drive that is required for connection to the system board.

If the BIOS does see the drive, set the drive to ATA compatible rather than AHCI and do the install.

 

0 Kudos
Gerald McFry
1 Copper

Re: E1505 Doesn't "see" brand new SATA HD

The  BIOS doesn't see the HD.  There doesn't seem to be an interposer board between the drive and the mobo.  I looked inside with a flashlight and it has the little holes that the pins on the HD go into.  I thought that might be the case, but doesn't seem to be...

There are no user setable parameters related to the SATA HD.  I don't find any place to set it to ATA or PATA or whatever!  Should I try and find a new BIOS and try and flash it?   Could it possibly be a bad motherboard???

Many Thanks!

0 Kudos
husky0894
4 Beryllium

Re: E1505 Doesn't "see" brand new SATA HD

Before condemning the board (which will be a $400+ repair) I'd try a different hard drive - it's possible the hard drive is faulty (yes, even out of the box).

 

0 Kudos
TheRealFireblad
5 Rhenium

Re: E1505 Doesn't "see" brand new SATA HD

 

... I'd try a different hard drive - it's possible the hard drive is faulty (yes, even out of the box).

 

But the drive worked/works fine in a different laptop Husky, and already has XP installed on it...

 

 

I even put the drive in an HP laptop, loaded Windows XP on it and it still gives me the same message.

From experience, I've found that:   “Beauty is in the eye of the beer-holder”!!

 

XPS M1730:

Smoke Grey Magnesium Alloy Chassis - with White LED Backlights
17" UltraSharp WUXGA Widescreen TFT (1920 x 1200) with TrueLife
Intel Core 2 Duo Processor T9300 @ 2.50GHz (800 MHz FSB, 4MB L2 cache)
4GB (2x 2GB) Patriot Signature PC2-5400 @ 667MHz
DUAL 512MB Nvidia 8800M GTX cards in SLi + 128MB Ageia PhysX
640GB SATA II (2x 320GB WD Scorpio Black 7200rpm)
8x Super-Multi DVD±RW
Creative X-Fi Notebook (ExpressCard) + Creative GigaWorks T40 Series II
Integrated 2MP Webcam
Dell Wireless 355 Bluetooth 2.0 Module
Intel Next-Gen Wireless-N Mini-Card
TV Tuner and Dell Travel Remote Control
4-in-1 Flash Card Reader (SSD/MMC/MS Pro/xD)

230W AC Adapter / 9-cell Lithium-Ion Battery

Windows 7 Home Premium (64bit)

0 Kudos
Highlighted
Gerald McFry
1 Copper

Re: E1505 Doesn't "see" brand new SATA HD

Actually, the BIOS does see the drive.  When I try to install XP, the XP installation doesn't see the drive.  I attempted to slipstream the drivers for SATA, but maybe I don't have the right driver.  Where can I get correct drivers?

 

0 Kudos
husky0894
4 Beryllium

Re: E1505 Doesn't "see" brand new SATA HD

You can download the driver from support.dell.com or get it from Intel.

 

0 Kudos