Highlighted
Thom CO
Phosphor

E6420 freezes on Dell logo, black screen

Hello,

I own a E6420 which I intended to rejuvenate a bit, by replacing the HDD by a SSD.

I replaced the HDD by the SSD but the SSD was not recognised by the bios. Hence I entered the BIOS and tried to change the SATA setting from RAID to ATA.

Oops. Very. Wrong. Move.

The laptop hasn't booted ever since. The dell logo shows, but when the progress bar is complete I only get a black screen. If I try to press F2 or F12, the upper right message shows (entering setup...) but the freeze happens anyway, usually with the upper part of the screen being black and the lower part still showing the remains of the dell logo.

What have I tried? Many boot tries:

- with the old HDD

- without any hard disk at all

- without any disk (no HD, no optical)

- with or without the battery...

- with a bootable Windows install DVD in the optical drive

- with a bootable USB diag stick made with https://www.dell.com/support/article/us/en/04/SLN143196/EN

All this with no avail.

I've also tried to clear the BIOS settings (going back to factory settings seems a good idea) by unplugging the cell coin battery. (and yes I did it by the book, with the power button down during many seconds sequence). After re-plugging the cell coin battery, the boot sequence is longer before the logo appearance (and funny enough, just plugging back the laptop starts it), but the end of the story remains the same. Pressing F12 gets to half logo freeze. Period.

Spent some time browsing this forum and others. I seem to have run out of options.

Has anybody got a brilliant idea? (or even an ordinary idea that would do the trick ;-) )

Thanks in advance,

Tags (1)
0 Kudos