Even After Updates Still Unusable

Updated everything on my 9550 after following the Dell recommended install guide. 

Remaining Issues:

1. Only way dock works is by connecting to dock after a complete shut down and restart of windows. If connected while hibernating only the monitor works. The USB and Ethernet do not. USB audio is very glitchy - sometimes it will remain connected sometimes it wont.

2. No stability. After "working" for a variable amount of time 5 min to 30 min... monitor will flicker (displayport connection) and dock will drop all USB connections and ethernet. 

3. Fan constantly running on low in the background. If on AC adapter... Fan shuts off.

4. Once connections are dropped. Laptop needs to be completely restarted before it will even consider connecting. Then if connects it will constantly drop USB/Ethernet and constantly try to reconnect. 

Update is effectively useless. Dell needs to fix this or I will be forced to return it. 

0 Kudos
7 Replies
Moderator
Moderator

RE: Even After Updates Still Unusable

Hi DIONJOHNWALLACE,

What the exact dock model that you are using? Did this issue occur recently or did was this seen from the start?

Update the BIOS for your system - http://dell.to/1TVhVoS

Also, reinstall the chipset drivers from the same link above.

Reinstall the displaylink drivers - http://bit.ly/1T8FdoX

Reinstall the drivers for your Dock - for WD15 - http://dell.to/1SPcbrA

And for Thunderbolt TB15 - http://dell.to/1qXRwvi

Keep us updated.

0 Kudos
4 Beryllium

RE: Even After Updates Still Unusable

Hi DIONJOHNWALLACE,

Thank you for writing to Dell Community Forum.

What is the BIOS version updated on this system?

Please update the BIOS to the latest available from our Dell Support Site

http://dell.to/23K8ds9

Please private message us the service tag of the system along with your email id along with the result from the above step.

(Note: please don't mention the service tag or email id on the public forum as it contains your personal information).

Regards,
DELL-Akshatha M
Social Media and Community Professional
#IWork4Dell

DELL-Akshatha M
Social Media Support
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

0 Kudos

RE: Even After Updates Still Unusable

This is the latest BIOS that I installed:

Dell XPS 15 9550 A06 System BIOS

 View details 
File Name: XPS_9550_1.2.0.exe
Description: Windows/DOS (9.21 MB)
Version: 01.02.00 ,01.02.00
0 Kudos
Moderator
Moderator

RE: Even After Updates Still Unusable

Hi DIONJOHNWALLACE,

Thank you for the update. 

We shall check on this with our PG team and keep you posted at the earliest possible, once we get any updates.

0 Kudos
Moderator
Moderator

RE: Even After Updates Still Unusable

Hi DIONJOHNWALLACE,

Apologies for delay in response.

We are still working on the case and shall provide any updates possible once we get a response from our PG team.

If by any means you have managed to resolve the issue, kindly keep us posted about the same.

Could you also kindly send me a private message with the service tag of the system and your contact details for case records?

Kindly keep us updated.

0 Kudos
Moderator
Moderator

RE: Even After Updates Still Unusable

Hi DIONJOHNWALLACE,

The updated drivers have been released today and are available on the support site - http://dell.to/1SNpxHE

Please reinstall the drivers and restart the system and the dock and check the functionality.

Keep us updated.

0 Kudos

RE: Even After Updates Still Unusable

Awaiting your response on the status of the system after the update.

Do reply to this community thread so that if there are any more queries we will be glad to assist you.

DELL-Infant R
Social Media Support
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

0 Kudos