dl__
1 Copper

RE: Flickering horizontal lines always on screen (XPS 15 9530)

I am having this exact same problem with my XPS 15 9530. I've carried out the suggested diagnostics. Here are the results:

Safe Mode: STILL VISIBLE

External Monitor: NOT VISIBLE

LCD BIST: Visible on the gray screen only

From reading through the rest of this thread, these results seem to indicate a screen problem rather than a software or system board problem.

My laptop is still under warranty. How can I get this fixed?

0 Kudos
kanu978
1 Copper

RE: Flickering horizontal lines always on screen (XPS 15 9530)

bump

0 Kudos
krisbio
1 Copper

RE: Flickering horizontal lines always on screen (XPS 15 9530)

Hi,

I am now experiencing the same issue.... Smiley Sad how can I get it fixed? unfortunately my laptop is no longer under warranty

Kind regards,

Kris 

0 Kudos
joe griff
1 Copper

RE: Flickering horizontal lines always on screen (XPS 15 9530)

Hi I'm having the same issue with my dell precision m4800.

Did you manage to resolve anyones issues?

Cheers

0 Kudos
Highlighted
LCWShop
1 Copper

RE: Flickering horizontal lines always on screen (XPS 15 9530)

Same issue for me, are there any solutions?

This issue seems to be hardware related.

Please tell we what I can do now.

0 Kudos
kevin.mcgue
1 Copper

RE: Flickering horizontal lines always on screen (XPS 15 9530)

I have the exact same issue on my Dell M3800. I bought my laptop from Dell in the US and am currently working in Japan, but Dell Japan won't help me because I didn't buy it from them.

The flashing lines are especially distracting when using software with gray backgrounds, like Adobe software. The flashing at the bottom is so bad it gives me headaches and nausea in a few minutes, basically making my expensive laptop unusable.

0 Kudos
SDolha
1 Copper

RE: Flickering horizontal lines always on screen (XPS 15 9530)

It happened to me too (with Dell XPS 15 9530), about 6 months since purchasing. Had contacted an authorized Dell Service partner and got the screen replaced. But after about 2 more months the replaced screen started to behave the same, although the lines are smaller and do not appear at all times (but when they do appear they are only really visible if the screen background color is around RGB 64-64-64). It seems to be related to electricity or something (i.e. sometimes lines appear differently when on AC vs. battery.) I will try to live with the problem, hoping it doesn't get more troubling.

0 Kudos
DModi
1 Nickel

RE: Flickering horizontal lines always on screen (XPS 15 9530)

I've got an M3800 which is an identical build to the XPS15. I had my screen replaced in May due to some dead pixels appearing - after a week I started seeing the problem with the screen flickering.

My suspicion is that a faulty or refurbished screen was used under warranty as a replacement screen. Needless to say, I've run all the tests (and them some more) above..

What I have noticed, is the vertical lines

  • are always formed from the same colour as the very bottom row of pixels on my laptop screen, and
  • they can change depending on the colour of the rows
  • the vertical lines or blacked out screen can also happen when the computer is starting up (i.e. on the boot screen)
  • if it happens on the Windows10 login screen the lines will be a different colour (the colour of the bottom row of pixels of the login screen), then they will change to the colour of the taskbar
  • it's the same patch of screen affected, about 5/6th of the screen has the lines or goes black, the remaining 1/6th to the far right either shows the rest of the screen or goes white/black

Above: The external monitor is a duplicate of the laptop monitor. The light grey lines on the laptop screen are from the open applications (as can be seen in the taskbar on the duplicated monitor - chrome (offscreen), spotify, outlook, google keep, citrix). The lighter mid-grey area to the very left of the laptop screen is created from the Cortana "Ask me anything" field in the taskbar.

Above: Only one application open this time (chrome), therefore only one light grey verticle line. Each shade of grey corresponds to the colour of the bottom-most row of the screen (the taskbar in my case).

Tests I've done...

1. Safe mode:  flickering lines still present. Changing the resolution from low to native in safe mode seems to make the flickering problem more apparent.

2. External monitor:  no flickering lines on the monitor at all, only seen on laptop screen

3. LCD BIST - solid colours ok (although catching the flickering problem at the same time as the BIST test is difficult to do as the flickering happens a lot, randomly (and often makes my screen solid black/white after a while)

4. Diagnostics - through the Dell website, nothing found

5. Driver update - checked all drivers and rolled forwards to the latest, backwards to the most stable, doesn't make a difference.

0 Kudos
DerekTrotter
1 Nickel

RE: Flickering horizontal lines always on screen (XPS 15 9530)

I am now having this exact problem. Machine is out of warranty. I had a tech come to my house and replace the Lcd at considerable cost and two days later it started again! Help. Very obviously a design flaw that Dell should step up and cover. This is like going to cost me a lot to fix.

0 Kudos
DModi
1 Nickel

RE: Flickering horizontal lines always on screen (XPS 15 9530)

Youre the first person ive seen to have this problem I besides myself.. good to know i wqsnt completwly alone! it's not the screen, try these:

- Update bios to A10 --- first time I did this the problem subsides for a long time

- Ensure video drivers updates all up to date --- this never worked for me but everyone says check the drivers.. so worth checking

- Check to see if you've had any windows updates in the last few days before you noticed the ptoblem happening; roll it back if you can and see if the problem persists --- I feel like this worked a few times for me as well. The problem seemed to occur after an update.  Not sure if it was a change to something slight that triggered the screen problem rather than being the underlying cause

- Go into safe mode and see if the problem happens. If not, because safe mode runs a lower resolution by default, up the resolution to 3200x1800 in safe mode --- for me this was the real test to pinpoint the screen or hardware as the problem. I only noticed the screen problem when the resolution was running full, even in safe mode.  It was at this point I called out Dell

- It could even be the motherboard. The early m3800s had some design flaws around keeping the power stable. My technician mentioned a potential faulty alternator.

Solution: sadly for me it was one of two things. The screen or the mainboard.  I can't tell you which because whilst replacing my screen the technician shorted my motherboard and took out the entire mainboard which had to be replaced before he machine would turn back on. I ended up replacing the mothetboard, could, gpu and screen. The problem hasn't been seen since.  Try all the above then think about either a new reen again (maybe just bad luck for you) or a new mainboard...

Let us know how you get on...

0 Kudos