PhilLewin
1 Nickel

How to boot UEFI usb drive on Dell XPS 13 L322X

Jump to solution

Hi All,

Dell update popped up new update. Installed. Shut down. Following the update. The laptop loaded up with (probably coincidence):-

Recovery

Your PC/Device needs to be repaired

The Boot Configuration Data file is missing some required information.

File: \BCD

Error code: 0xc000000d

Attempting to get the Win 10 usb image to boot in UEFI mode doesn't seem to work. Wasted 3+ hours so far looking for solutions. Why can I not change the boot priority order in the bios? UEFI boot seems to always default to windows boot manager irrespective of any selection made. Am I going to have to remove the drive and repair the boot drive.

Anyone managed to boot from external dvd image successfully?

Is the A10 bios locked/limited? Is there a way to unlock?

Great way to ruin my bank holiday. Wife is moaning Smiley Sad

Any help/links would be much appreciated.

    Cheers

   Phil

0 Kudos
3 Replies
9 Rhodium

RE: How to boot UEFI usb drive on Dell XPS 13 L322X

Jump to solution

Check you UEFI setup to make sure the update didn't change the drive mode (AHCI to RAID, etc.).  If it did, you'll see that problem.

0 Kudos
Saltgrass
4 Ruthenium

RE: How to boot UEFI usb drive on Dell XPS 13 L322X

Jump to solution

You will normally use an F12 key to open the Boot Device Menu.  If you have burned the .iso image to the DVD and have it loaded BEFORE you boot or reboot the system, the UEFI version should be seen.  You may have to hit a key to allow the boot but there should be a message if that is required.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
PhilLewin
1 Nickel

RE: How to boot UEFI usb drive on Dell XPS 13 L322X

Jump to solution

Hi,

Managed to repair it! Leaving this here in case it helps anyone else with similar problems.

Sata mode was AHCI.

Using F12 for boot menu does not show the usb boot device by default. It has to be added manually in the bios.

Disable secure boot.

When adding a new boot device you give it a name which appears under the (F12) boot menu. Next you select the usb device listed (Easier if there is only one plugged in!).

IMPORTANT PART! Filename -> Don't try entering the filename manually. Press enter and you will be presented with a simple file browser. Browse to efi\boot and select bootx64.efi.

If the filename is not correct selecting the new usb boot option in the (F12) boot menu will just appear to be booting as normal ignoring your selected boot device.

Once I had booted into Win10. Selected repair->advanced and then command prompt.

typed:-

BOOTREC /FIXMBR

BOOTREC /FIXBOOT

BOOTREC /REBUILDBCD

then reply 'y' to the question. All should complete successfully. Then remove usb drive and reboot. Win10 back up and running.

0 Kudos