1 Copper

Inspiron 15 5567 Troubles. Plugged in but not charging.

Hi,  I’m having a bit of a problem and I was hoping for some advice. A couple days ago, I dropped my laptop. It wasn’t a long fall, maybe a foot and some inches. It fell off of my bed and onto the floor, which is carpet. It fell on the side which had the power plug in it, which caused the cable to bend a bit bit there was no other damage. I noticed the day after that the laptop was not charging. I panicked and bought a new charging cable. When I plugged the new one in, it worked for a second but then went back to saying “plugged in but not charging”. Currently my laptop is at 3% and is not changing.  Which makes me think that maybe the laptop is not as broken as I thought.  The AC port, as far as I can tell has no damage. The gold prong in there still looks very straight.   I ran a dell diagnostic and it said that nothing was wrong with the battery. For both AC power cables( the new and one) the laptop seems to know that they are plugged but do not recognize them.  In the BIOS setup, the batter is stuck in idle.  I really need my laptop because I am in school and I’m not sure if I can afford any kinds of repairs right now.  I have tried going through dell for help and they did not exactly provide. I also tried to update the BIOS through dell but maybe laptop is on 3% and I needed 10%.  Also my laptop does not have an external battery so I can’t remove it and then plug it back in.  Sorry about the word vomit. I would appreciate any and all advice because I am getting desperate.

0 Kudos
2 Replies
5 Iridium

RE: Inspiron 15 5567 Troubles. Plugged in but not charging.

Hardware damage won't be fixed with updating the BIOS or any such nonsense.

0 Kudos
8 Xenon

RE: Inspiron 15 5567 Troubles. Plugged in but not charging.

There is a hardware problem -- a BIOS update won't fix it.

First try a new (or another; most computer shops will have one you can use to test) Dell AC adapter.  If that solves the issue and gets the adapter recognized, you're set.

If not, replace the DC jack:


... and if that doesn't do it, the charge circuit on the mainboard is bad;  replace the mainboard.

0 Kudos