Highlighted

Inspiron 15R SE 7520, Windows 10 x64, ATI BSOD

Hello, get constant BSOD when trying to install drivers for ATI videocard for Inspiron 15R SE 7520 (7730M) on new Windows 10 Creators Update

Trying all drivers, from Dell site, from ATI site

Integrated Intel HD4000 works good, but when installing ATI driver - BSOD, only restore to last save point helps.

What can i do?

2 Replies
Moderator
Moderator

RE: Inspiron 15R SE 7520, Windows 10 x64, ATI BSOD

Hi KULIKOVPAVEL,

The Inspiron 7520 is not tested by Dell for Win 10 Creators Update and hence could be the reason you are unable to install the AMD drivers. Kindly review the article here - http://dell.to/2qjc6qe 

Kindly try installing the drivers from the vendor site - http://bit.ly/1KQ8xMC - and check if it works.

Also, please click my DELL-username and write me a private message with the service tag and your Name for case records.

Let us know if you have any other queries.

Thanks and Regards,
DELL-Rishi
Social Media and Communities Professional
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

0 Kudos
Amalgame17
Copper

RE: Inspiron 15R SE 7520, Windows 10 x64, ATI BSOD

Hello, i have got the same configuration and finally manage to make 7730m HD to work properly:

1. Install the creator update. You can have BSOD because of the 7730m drivers when you start your computer

2. Go to safety mode to unable 7730m. You can now restart your laptop and use it in normal mod.

3. Install all the windows updates.

4.  install the last update for the BIOS (from dell website)

4. If you have not a clean install of the drivers use DDU or amd cleanup to start drivers installation from scraths.

5. Install Intel drivers. I use the  win64_153345.4653 version downloaded from intel website (07/04/2017 in device manager)

6. Install the ATI drivers. For that, be sure you have disabled the defender center and run the installation in admin mod. I install the 17.9.2-Sep21 version express mod.

You may have freezing when trying to restart your computer at the end of the installation. If it is the case, go to safe mod and adapt your power options and your register. If i got it correcty, the problem with the graphic card is linked with a specific power state (ultra low power setting) that is not poperly working with neither creator update  nor the laptop. To disable this option, two things need to be done :

1 : regedit and set the register key EnableULPS to 0.

2: in power setting go to advanced options and set :

AMD PowerPlay  "max performance"

Intel Graphics Setting to  max performance

PCI express ; link state power management to disable

Finally update the driver of 7730 to use the windows 10 one in your device manager  (date : 22/06/2015...)

Worked for me ! i can use 3D software and games (tried with portal2). The only thing is that i use a 2years old driver.

I hope this post will help you to get through your problem.

Best regards

0 Kudos