Fozzie Bear
1 Nickel

Inspiron 17R (N7110) Video issue

I have just taken as part exchange an Inspiron 17R with Intel i3 processor and Windows 7. It needed to be wiped of the customers data and program so I did a factory reinstall followed by an upgrade to windows 10. All went well and the laptop was running well until I started browsing the internet using Edge. 

At times the picture broke up and went into what I can only describe as a jagged image across the whole screen (see attached photo). Eventually it stops and returns to normal. I tried the same websites using Google Chrome and the picture was fine if Edge was closed. However if Edge was open in the background the same problem occurred in Chrome.

I therefore thought it was a problem with Edge and continued to use Google chrome instead until the same problem occurred using Chrome

I therefore went to the Dell website and ran the Hardware diagnostics program that can be downloaded. This stress tested the video card running at all frame rates and resolutions and it passed all tests. I also ran several DVDs on a loop all day and it didn't miss a beat so assumed it was still a browser related issue.

Checking the Event Viewer however I found several error entries related to Windows Media Centre. Windows 10 does not include Windows MCE so I concluded it was left over remnants from the Windows 10 Upgrade. I therefore did a Reset (not refresh) of Windows 10 to undertake a clean install of the OS. Again everything in Device Manager was correctly installed including the latest Intel Video driver for the i3 processor. 

I thought I had resolved it but two or three days later the problem returned. I have tried flexing and moving the display(lid) and this does not cause problems so don't think its the cable from the motherboard to the LCD.

Does anyone have any ideas what might be the problem here? Is it hardware or a software issue?

1 Reply
Damadell
1 Copper

RE: Inspiron 17R (N7110) Video issue

I have the exact same problem with my n7110.  Happens sporadically on all sorts of browsers applications.  Anyone have an answer for us?  Is it a Windows 10 issue, since Dell won't test this machine on 10?