Laptops General - Read Only

Last reply by 06-26-2017 Unsolved
Start a Discussion
2 Bronze
2 Bronze
738

Inspiron 3520 will not post or go past Dell Logo

one of my machines that I rarely use I needed to put into service. I hit the poert button and it go's to the Dell logo but no further. No movement on the status bar, no nothing. I tried Hard power down (battery out Unplugged hold the power button for 8 seconds) No change. I opened it up and one by one removed componets, dvd...no change Hard drive...no change...CMOS Battery...got 5 beeps (DUH) put battery back in...no change  OK now what to try...HELP

Replies (2)
Dell Technologies
332

Hi Antranch_1,

Thank you for writing to Dell Community Forum.

Can you check if you are able to run the on-board diagnostics <F12>?

Please click my DELL-username and send me a Private Message with the Dell Service Tag number and your email address.

DELL-Akshatha M
Social Media Support
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

Dell Technologies
332

Hi sandstorm_1,

Thanks for posting.

Please post what operating system you're using.  

Have you tried pressing F2 while the computer is booting up to see if you can get to the BIOS?  Is the hard drive recognized by the BIOS?  If not, you may either have a motherboard failure or a hard drive failure.  Any beeps when booting up?  Please post back with your findings.  Thanks.

Latest Solutions
Top Contributor