Profvip
2 Bronze

Inspiron 5520 No bootable device may be due to un-intentional corrupted bootloader

Dear colleges and respectful Intel engineers.

while working in an operating systems project about writing bootloaders and kernels to USB flash memory. 

I used a program to write the bootloader.bin to the first sector of the USB. 

Un-intentionally I wrote the boot.bin to my HDD after reboot the following message appears

(I'm not sure 100% if that happens but I put a guess) : 

PXE-MOF: exiting pxe rom no bootable device dell

I don't want to re-install or re-format a new operating system 

I want a solution to recover the bootloader and resume my installed operating system normally.

My Laptop : DELL Inspiron  5520 - Running windows 10 - and containing VM Virtual box also I enabled the virtualisation in the BIOS setup. 

Note:

1-I tried to change some settings in the BIOS Setup but hopeless

 2-I tried to re-seat the hard-disk once and didn't try again (not solving the problem also).

0 Kudos
2 Replies
Profvip
2 Bronze

RE: Inspiron 5520 No bootable device may be due to un-intentional corrupted bootloader

I did the following :

install miniTool Partition Wizard Bootable 9.1 free edition on USB.

bootingfrom USB the hard drive is shwn as a single un-allocated block

so I make the following :

1-rebuild the MBR

2-recover the partitions

after applying the hard drive now is shown and partitioned properly with the same label and sizes.

but after rebooring and set the system BIOS to optimal also same error occur : No Boot Device Found. Press any key to reboot the machine.

Any help ?

0 Kudos
Profvip
2 Bronze

RE: Inspiron 5520 No bootable device may be due to un-intentional corrupted bootloader

some updates :

Using the same software : MinTool Partition Wizard 9.1 - Bootable

I did a full scan not a quick scan

this time a block with label boot appears and it is defined with status Lost/Deleted

 [its used size = 2.45 MB and total size = 3.01 MB]

other blocks appear also with file system Ext4 [Possibly old partitions for a fedora linux installed before but not use them now] and defined with status Lost/Deleted

the problem here that the boot sector start and end LBA are interleaved with existing block contains my operating system [C Partition]

Strange thing that my partitions that are recgnized well in the quick scan apper repeated one time with status existing and with actual last well defined info and other times with status lost/deleted and with old information and interleaved sector numbers.

I'm still in 95% of the scan if there's any advice it would be greatly appreciated.

Data:

File System - Label - Starting LBA   - Ending LBA - Used Size - Size - Status

NTFS -System Reserved         - 2048          -206846       -30.03MB   -100MB       -Exisiting

NTFS -No Label(Possibly C:) -206848       -307210993-139.78 GB -146.39 GB-Exisiting

NTFS -Boot                                 - 52569120 -52575292 -2.45 MB     - 3.01 MB    - Lost/Delted

FAT32-No Label                        -171949088-205501471-16.01 MB - 16.0 GB      - Lost/Deltetdd

Ext4   - No Label                       -183621184-200396351-326.43 MB - 8.00GB     -Lost /Deleted

Ext4   - No Label                       -183641736-200416903-274.56 MB - 8.00 GB    -Lost/Deleted

three Ext4 partitions appear. 

NTFS-Study (E:)                       -303217072-1038206880-167.76GB-350.47GB-Lost/Deleted

NTFS-Study (E:)                       -307211000-104220080-334.33GB -350.47 GB - Existing 

and many other partitions appear some with Existing status (and they are correct other with Lost/Deleted status).

0 Kudos