Highlighted
alan2000
1 Copper

Inspiron 7567 - New SSD not showing up in windows 10

Hello guys! I recently bought a Micron M600 2.5" SSD drive for my laptop but it won't show up in W10 disk manager, device manager or diskpart.

I currently have the stock 256GB M2 SSD installed and want to use the new 2.5 SSD for game storage, however in BIOS I can see the 2.5" SSD if I disable secure boot but again not in W10, already changed the setup of SATA from Raid to ahci and still not showing up.

If I install a normal HDD it will show up in windows without any issues.

Have also connected the SSD with an external caddy and it's fully working and being recognized by W10.

My laptop model is the inspiron 7567 Core i5 variant.

Any help would be greatly appreciated!

0 Kudos
8 Replies
Saltgrass
4 Ruthenium

RE: Inspiron 7567 - New SSD not showing up in windows 10

Enabling or disabling Secure Boot should not matter for a new non-bootable or non-initialized drive.

I am running my system with the .05 bios update, with a M.2 PCIe configuration but do not have a 2.5 inch drive installed.  If the drive were clean or uninitialized, it should show up with either AHCI or RAID since that seems to control the M.2 slot.

If you can't get it to work, I can install a 2.5 inch drive on my system.  Currently I am thinking about doing a clean Win 10 install since the wireless driver is giving me Blue Screens in the Creator's Build.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
alan2000
1 Copper

RE: Inspiron 7567 - New SSD not showing up in windows 10

Booted from a usb with W10 and there I am able to see both of my SSDs, but it still wont show up on my internal W10, seems like I will need to install a fresh copy of W10 on my M.2 and see if that helps, I am completely clueless.

You could try and see if it reads a 2.5 inch ssd, if all of this doesn´t work will just install a normal HDD :\

0 Kudos
alan2000
1 Copper

RE: Inspiron 7567 - New SSD not showing up in windows 10

Have booted on W10 with a usb and there I can see both of my SSD drives(M2 and 2.5) have, will try to do a clean install of w10  too on my main SSD and see if that finally resolves the problem.

It is driving me crazy that it wont show up on my internal W10

0 Kudos
Saltgrass
4 Ruthenium

RE: Inspiron 7567 - New SSD not showing up in windows 10

OK, I will try one to see how it works.  I just did a clean install of the latest Win 10 build so it may take me until tomorrow to try the extra drive... I will let you know...

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
Saltgrass
4 Ruthenium

RE: Inspiron 7567 - New SSD not showing up in windows 10

Well, I just installed a Samsung 850 Pro 256 GB and it was recognized.  I had cleaned the drive prior to the install and had to initialize it in Disk Management.

Once a drive letter is assigned to it, the drive should be readable.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
alan2000
1 Copper

RE: Inspiron 7567 - New SSD not showing up in windows 10

Found a solution! I deleted the intel sata drivers and after restarting the laptop my SSD was there ready for use, thanks for your time bro! Smiley Happy

0 Kudos
Saltgrass
4 Ruthenium

RE: Inspiron 7567 - New SSD not showing up in windows 10

You are welcome.. I suppose I need to install the Intel driver to see if it causes problems for my system.

----------------------------------------------------------------------------------


XPS 2720, Inspiron 17 7779, Inspiron 15 7567, XPS 13 9365, Inspiron 1545, TB16 Dock

0 Kudos
PicassoDeGallo
1 Copper

RE: Inspiron 7567 - New SSD not showing up in windows 10

I'm having a similar problem to you and I've found this thread to be the most relevant. I deleted the "Intel Rapid Storage Technology" drivers and still no success. Did you also have to re-install windows?

I'm trying to get my laptop to recognize an older Crucial M500 SSD. It's not clean, but I'm not sure how to clean it if I can't see it in device manager or... maybe reinstall windows.

0 Kudos