Highlighted
jessiejcjsjz
1 Copper

RE: Intermittent no audio on XPS 13 9343 (2015)

Post this in order to help more dell XPS 13 9343 users.

I bought my XPS 13 9343 with default windows 8.  I upgraded it to windows 10 today and found the same issue with you.

Downloaded and installed all the updated drivers, doesn't work.

Tried dell system detect and driver managers, automatically download failed. So I manually downloaded audio driver, in a loop of uninstallation, restart, installation, doesn't work.

Finally, I decided to the change BIOS to 9343_BIOS_Rev_A07,Dell XPS 13 9343 System BIOS; and restart the computer it works !!!!

So much pain...hope this help

Tags (2)
eldelacajita
1 Nickel

RE: Intermittent no audio on XPS 13 9343 (2015)

Finally, I decided to the change BIOS to 9343_BIOS_Rev_A07,Dell XPS 13 9343 System BIOS; and restart the computer it works !!!!

I don't know if this is a solution to the original issue, which comes from 2015. But I was getting cracking noises and no sound lately, and this solved it for me.

Now I still have to reinstall the Realtek drivers, which I removed in the process, but the sound now works fine, even without those drivers.

EDIT: I wasn't able to install the drivers, got the endless installation loop issue. But everything seems to be working fine with A07 bios and WITHOUT the drivers. 

0 Kudos
rwrobe
1 Copper

RE: Intermittent no audio on XPS 13 9343 (2015)

This continues to happen to my XPS 13 9343. After the A09 BIOS update, my audio stopped working. I've tried uninstalling and reinstalling the drivers, but doing so actually updated the DNS address on IPv4 for my wireless network, rendering that unusable for about 20 minutes until I figured it out!

I'm completely at a loss why drivers on this model notebook have been so much trouble. In the 18 months I've owned it, maybe one or two have passed with all components of the notebook working as they're supposed to.

The only thing that I did one day to the next that could have done something to the audio is shut the lid to carry it downstairs.

0 Kudos
tz_md
1 Copper

RE: Intermittent no audio on XPS 13 9343 (2015)

As I'm sure we've all been dealing with this for the past >1year, we've all figured out how to deal with this issue. But for completeness, I'll summarise my experience:

Win10 (upgraded from factory 8.1) dual booting Ubuntu 16.10 (upgraded from original install of 15.04).

Best chance of getting sound to work is booting Ubuntu twice in a row (not restart, a full shutdown+start, x2). Once sound is working in Ubuntu, great! Never switch back to Windows! You can even put the computer to sleep (closing the lid) and the sound comes back when waken up again. Same story in kernel

pre-4.2 and post-4.2 when the default audio mode changed from HDA to I2C.

If you MUST switch to Windows, for the love of God, don't ever close the lid or let the computer go to sleep. If you do, you will lose sound and will have to go through the process of two consecutive cold boots of Ubuntu and then another boot back into Windows. No combination of driver updates, reinstall, or even BIOS version will change or help this. Believe me, I've tried it all. For the record, I've kept all of my software and firmware up to date (currently BIOS A09), and still issues remain. For this reason I'm suggesting the revocation of the "accepted" status on the previous post.

So, in response to @rwrobe, yes it is because you closed the lid. Shame on you Smiley Wink

0 Kudos
lluke
1 Nickel

RE: Intermittent no audio on XPS 13 9343 (2015)

I'm experiencing the same issue. Already installed the realtek driver over again but now a few days later the issue is back.

0 Kudos
Jim Coates
6 Gallium

RE: Intermittent no audio on XPS 13 9343 (2015)

I'm suggesting the revocation of the "accepted" status on the previous post.

Done.

This thread was started by oRAirwolf, and it should be left up to him or her  to verify that any given post was the answer to the original question.

So far, there have been at least 8 different solutions suggested, but there has been no consensus around any of them.

Thanks for posting your solution. I have included it, along with the others, in the Recent Issues FAQ.

Jim Coates -- 15 years on the Dell Laptop Audio boards -- since 2/6/04 

0 Kudos
oRAirwolf
2 Iron

RE: Intermittent no audio on XPS 13 9343 (2015)

The only solution I found was to get a replacement XPS 13 9350, not another 9343.  I am pretty sure this was a hardware/manufacturing flaw and not something that could be fixed with driver tweaks.

0 Kudos
eldelacajita
1 Nickel

RE: Intermittent no audio on XPS 13 9343 (2015)

I am pretty sure this was a hardware/manufacturing flaw and not something that could be fixed with driver tweaks.

It really looks like that. I bought a Dell because of its great Linux support (compared to others), but dual booting has been a year-and-a-half long nightmare and there seems to be both no solution and no interest from Dell in finding one.

The only solution I found was to get a replacement XPS 13 9350, not another 9343.

Did you just buy the newer model and sell the old one, or got it replaced by Dell?

0 Kudos
oRAirwolf
2 Iron

RE: Intermittent no audio on XPS 13 9343 (2015)

Dell replaced it with a 9350, but this was due to this issue happening across a couple of 9343's for me, plus an issue with the trackpad.  It's worth asking, because it's obviously an issue that can't be fixed at the driver level, as it happens in both Windows and Linux.  A firmware fix might help, but at this point, I think it's absurd to think that Dell would fix a problem on a laptop that is almost 2 years old.  They'd rather you just buy their new one that doesn't have that problem.

0 Kudos