Highlighted
MackTruck
1 Nickel

Internet connectivity lost after reinstall of Win7 Home Premium

Jump to solution
Let me set the problem. My Dell XPS L502 is running Win 7 Home Premium. It has an Intel i7 processor and 8 gb ram along with a 750 gb hard drive. This machine started causing problems with some programs and the programs could not be installed. I had seen this problem a couple years ago and solved it by reinstalling Win7. Therefore, I tried the same thing this time only to find that after reinstalling Win7, many of the drivers were gone. Including drivers for my wireless card and USB ports. I still have the use of the DVD drive and Win7 runs but that doesn't do much good. I do have "synaptics" control but I do not like the "touch pad" so I very much prefer an external mouse. I have tried several things which do not work. Most recently, I tried to force the Recovery Partition to open up its secrets using a post at: http:://smsoftdev-solutions.blogspot.com/2009/03/how-to-restore-dell-factory-image-when-PC -restore-does-not-work This reference seemed to offer possible solutions but none that I tried would work. I have also read that once a "Reinstall Disk" has been used, the Recovery Partition becomes "unavailable" which is precisely what the above reference talks about. So how do I manage to install the appropriate drive to give me "internet connectivity" so I can go to Dell and down load the up-to-date drivers for my system. Thank you very much for all the assistance that you will provide to solve this issue.
0 Kudos
22 Replies

RE: Internet connectivity lost after reinstall of Win7 Home Premium

Jump to solution

I also recently reinstalled windows 8......

you can connect your pc through Ethernet and then download drivers for wifi.......

I did this myself

0 Kudos

RE: Internet connectivity lost after reinstall of Win7 Home Premium

Jump to solution

use your service tag to get the drivers from dell.com

0 Kudos
MackTruck
1 Nickel

RE: Internet connectivity lost after reinstall of Win7 Home Premium

Jump to solution
Thanks for the suggestion. Unfortunately the Ethernet drivers have been compromised along with lots of other drivers. It would be lots better if there were some useful way to access and use the "Recovery Partition". The suggestions mentioned in my earlier post did not work for me.
0 Kudos
MackTruck
1 Nickel

RE: Internet connectivity lost after reinstall of Win7 Home Premium

Jump to solution
The Service Tag suggestion was quite appropriate. Eventually, I did reach a Tech Support agent at Dell and spent more than an hour, mostly listening to dead air, hashing out that I did in fact own the machine I referenced. After all of that the Tech suggested sending me an "Install Disk" with the, I hope, drivers that I need to get back up and running. I appreciate your suggestion.
0 Kudos

RE: Internet connectivity lost after reinstall of Win7 Home Premium

Jump to solution

as I told you I myself recently Formatted the system. after format was complete all the drivers were gone, which is absolutely normal but the Ethernet was working. As you have formatted the system all the drivers must have gone. you can troubleshoot your Ethernet using control panel. also you can download drivers from another pc or your phone.

hope it helps  

0 Kudos

RE: Internet connectivity lost after reinstall of Win7 Home Premium

Jump to solution

I don't think you can access recovery partition to get the particular files or drivers. Recover partition is used to restore the pc to factory condition. using recovery partition will also restore your divers

0 Kudos
Moderator
Moderator

RE: Internet connectivity lost after reinstall of Win7 Home Premium

Jump to solution

MackTruck,

When you reinstalled the operating system, did you install the Dell System Software(if applicable) and the chipset drivers first? If not, the rest of the drivers will fail to install. How to Download and Install Drivers in the Correct Order

Start with the Dell System Software and the chipset drivers and follow the list.


Rick

#DellRockstar

What is a Dell Service Tag and how do I locate it? 

Original poster, If you have solved your problem, can you please mark the correct thread(s) with your solution. Thanks 

Welcome to Dell Community!

#DellWorld 2012

#DellWorld 2015

#DellEMCWorld 2016

#MicrosoftMVP - Windows Expert-Consumer April 1, 2012 to March 31, 2015

0 Kudos
MackTruck
1 Nickel

RE: Internet connectivity lost after reinstall of Win7 Home Premium

Jump to solution
Rick, May I request some clarification. I did reinstall "Reinstallation DVD Windows 7 Home Premium SP1 64-Bit" which came with my computer. I did not install the "Dell System Software" because I do not have this disk. I was led to understand when I talked to a Dell Tech person that it was this "Drivers and Utilities" Disk that is being shipped to me as of Friday. I was under the impression that this disk would provide the "Dell System Software" and other drivers that are needed to get my system up again. Please correct my assumptions if you find them in error. When the disk arrives, are there any special methods that I should use to get the proper software installed on my system? Or, is it as straight forward as inserting the disk into the drive and "letting it do its thing"? I have the document that you suggested and will print that soon. You input and suggestions are truly appreciated. Paul Holm
0 Kudos
MackTruck
1 Nickel

RE: Internet connectivity lost after reinstall of Win7 Home Premium

Jump to solution
DANISHHAF1Z007 Thanks for the suggestion. As it happens, I've tried your solution of using another PC, only to find that the list of drivers, etc. for my XPS L502 is not complete and I don't know how to force the Dell Support page to give me the OEM list of drivers. I have (had before disaster) updated the drivers for the system and now I only get a list of suggested drivers with no indication of which are the ones I need. Any and all suggestions are welcome and appreciated. Thank you so very much.
0 Kudos