ck787
Not applicable

Keyboard Lag: XPS 13 (9333)

Jump to solution

Hello,


I'm on my second XPS13 (9333) because of a keyboard latency (lag) issue.  I've found that if the AC adapter is plugged in there is no lag.  When the AC adapter is NOT plugged then the problem occures.


The keyboard has no problems in Safe Mode.  Dell sent a USB to reload the OS but that did not fix the problem.  I've heard from another poster (different site) that Dell replaced the MB, SSD, CPU and that did not solve the problem.


I appreciate any insight others may have.

Thank you

0 Kudos
1 Solution

Accepted Solutions
suffestuffie
2 Bronze

RE: Keyboard Lag: XPS 13 (9333)

Jump to solution

I think i have a solution for you:

Start Intel Rapid storage technology center and disable SATA link power management. 

I also had another keyboar issue, it was generating numbers (2/4/6/8) when using the arrow keys. This has been solved by updating the BIOS.

View solution in original post

0 Kudos
7 Replies
cpncrisp
Not applicable

RE: Keyboard Lag: XPS 13 (9333)

Jump to solution

Hi,

I'm also having the same keyboard lag problem on my XPS 13 9333 - super annoying and I'm probably going to return it. Seems to be a driver issue. 

The lag only happens with the laptop's keyboard. If I connect a USB keyboard, there's no problem there and typing is instant.

I installed a fresh copy of Windows 8.1 on it, and began experiencing the keyboard delay after installing the Intel 4400 Graphics driver from Dell or Intel's site, I've tried both.

The only thing that solves it is by running msconfig or services.msc, disabling the "Power" service, and then restarting. This solves the keyboard delay issue, but also disables power options which decreases battery life etc so not a solution really.

Can someone from Dell please investigate? This sounds like some kind of feature in the graphics driver that depends on the power service or one of its dependencies that's causing the keyboard delay.

Thanks,

Eugene

0 Kudos
jpkerloch
Not applicable

RE: Keyboard Lag: XPS 13 (9333)

Jump to solution

Hello,

Your are not alone !!! I have the same issue !!! No investigation of dell !! pfff

You use a dell driver for your graphic card or intel driver generic?

0 Kudos
suffestuffie
2 Bronze

RE: Keyboard Lag: XPS 13 (9333)

Jump to solution

I think i have a solution for you:

Start Intel Rapid storage technology center and disable SATA link power management. 

I also had another keyboar issue, it was generating numbers (2/4/6/8) when using the arrow keys. This has been solved by updating the BIOS.

View solution in original post

0 Kudos
barry.r
2 Bronze

RE: Keyboard Lag: XPS 13 (9333)

Jump to solution

I think i have a solution for you:

Start Intel Rapid storage technology center and disable SATA link power management. 

Thanks for posting a solution to this very annoying issue. Unfortunately it didn't seem to work for me. 

Has anyone else had success with this solution? I'm keen to see if anyone else has been able to solve this very annoying problem!

0 Kudos
tjtyers
2 Bronze

RE: Keyboard Lag: XPS 13 (9333)

Jump to solution

Hi There.

I've tried this solution on my XPS13 (9333) and it doesn't fix the issue either. I have been trying to figure this one out for months, but have never come across a solution.

Plugging in the power cord is the only thing that makes the lag go away. The problem is definitely in software however, because when I install Ubuntu linux on the XPS13 there is absolutely not keyboard lag.

This issues is incredibly frustrating! It ruins what is otherwise a great laptop!

0 Kudos
Timmo2
Not applicable

RE: Keyboard Lag: XPS 13 (9333)

Jump to solution

Thank you, this solved my problem. I do wonder, though, if disabling the SATA link power management will cause other problems.

0 Kudos
xsivke
Not applicable

RE: Keyboard Lag: XPS 13 (9333)

Jump to solution

For Windows10, the Intel Rapid Storage is not compatible. 

Follow this ljnk to solve this in Windows10

www.greigmitchell.co.uk/install-intel-rapid-storage-technology-driver-on-windows-10

0 Kudos