Highlighted
StarbucksSteve
1 Nickel

L702x will not boot from GPT (GUID) partitioned device

 

I have never had this issue before; I have installed MAC OS X and Linux on a dozen Dells (including an L701x last month) all of which boot from GPT drives without a hitch.

Not only can I not partition the disk as GPT, I cannot partition it MBR in any OS other than Windows.  I used the MAC OS to build a MBR disk, installed Windows to it and it would not boot.  I then attempted to restore Windows on the same disk using the Dell restore procedure and the restore process reformatted the entire drive wiping out the restore partition in the process (it went from 13.86GB to 786MB as a result of this process).  I tried it 2 more times with the same result.  Finally, I used Windows for the MBR partition process and the result restores and boots without issue.

The message from the failed boot is "Operation System not found"; I find it interesting that the message is not "Operating System not found".  Either the BIOS has been rewritten with a new message or the process is dying at a different location and the message is supposed to be some sort of indication of the actual error.

Bottom line, I believe this to be a Dell BIOS issue in the Sandy Bridge machines and I need it fixed, soon, or they're gonna get this one back as I cannot live with a machine which will not service my needs. 

I am running the A10 BIOS in this L702x; I have attempted this with every available BIOS; A04, A05, A07, A08 and A10.  None of them work.  I should mention that this is not isolated to my machine as I have seen a number of reports of this issue under FreeBSD, MAC OS X and Linux forums on both the L702x and L502x ...

 

0 Kudos