Laptop/DVD Drive doesn't recognize Alienware Respawn DVD with Windows 7 on

Hi there,

I have Alienware m15x, which I purchased in January 2010. Recently I planned to format my HDD and install everything back again using included Alienware Respawn disc with Windows 7 x64 bit on.

The problems started at the very beginning. I mean, computer can't recognize this disc. It doesn't see it even inserted. I found some very small circle way scratches on the disc (never used, first time opened the cd cover).

Tried to reboot couple of times, with no effect, so I tried to copy this disc on other computer which detected and read this disc correctly. Copied disc inserted to my Alienware. At the first time, it showed me this disc blank, available to burn. After reboot showed this disc kind of correctly. Showed in Windows Explorer disc content. Then I reboot comp again, but didn't manage to boot disc. Windows launched and tried to read this disc. Since then, at all times it finds it blank disc, available to burn.

After all, I was going to try update firmware of the DVD drive. Downloaded from Dell site. App showed me that I have D500 fw, while the latest is D800. So I launched app to update it, but every time I try to do it program seems to freeze and doing nothing, while Task Manager shows it running. During this operation I get the following message:

"The firmware update process of this company is organized so that the entire upgrade process is completed after the PC is automatically rebooted. Therefore do not off the PC power supply by force while the upgrade is in process"

So I left it, but nothing happened for next 3 hours. When observed no activity I rebooted by myself. Firmware stood still with the old one.

I am running Windows 7 x64, originally installed by Alienware. My disc drive is called: TSSTcorp DVD+-RW TS-T633C. No special programs running in the background, besides Kaspersy Internet Security 2010, Virtual CD ver. 10.x and Skype.

So my questions are:

1) Why can't I read this disc correctly, while other normal discs such as game discs, DVD-Video and many others are recognized correctly?

2) Why doesn't it update my firmware?

3) What I have to do to solve it? (Kind of obvious question Smiley Wink )

0 Kudos