JNXU
1 Copper

Latitude 5289 Connected Standby & S3

So, we are currently trying out the Latitude 5289, but i discovered a several problems.

It seems like out of the box the Standby-state S3 is not supported, but only Connected Standby. This might work out with some Intel M5 without active cooling but definitely not with an i5. (Some Test-Users reporting the fan spinning at max speed, after closing the lid and putting it in a laptop case.

So I found, thanks to some Surface Forums, the possibility to disable the connected Standby by registry key ( HKLM\System\CurrentControlSet\Control\Power\CsEnabled 1 -> 0 )

After that powercfg /a also shows S3 enabled.

This Sleepstate does work while I start it from the Windows-Powermenu, but not works while closing the lid (Notebook crashes while recovering from sleep)

But the main problem with S3 is, when the device wakes up again, the touch screen doesn't work anymore. Also tried the newest Wacom driver for wcom&dev_4848 and set up, that windows can't turn the device of to save energy. Only way I figured out to re-enable touchscreen is a reboot. No changes yet.

Bios version is 1.6.1 with newest drivers.

Anyone else got problems with Standby?

0 Kudos
2 Replies
Moderator
Moderator

RE: Latitude 5289 Connected Standby & S3

JNXU,

Check the settings in the bios under the power management screen options that refer to the Block Sleep and Wake on Lan section.

Social Media Support
#IWork4Dell
To help us troubleshoot, send us via a private message: Dell PC or Monitor Service Tag number
Out of Warranty Support
Where do I find my Dell PC Service Tag or Express service code?
Where do I post SA (SupportAssist) issue/questions?
0 Kudos
JNXU
1 Copper

RE: Latitude 5289 Connected Standby & S3

Wake on Lan is not supported by the device, the Block Sleep (S3 State) is disabled.

0 Kudos