Highlighted
lankylad
6 Indium

Latitude D420 Modem Driver Windows 7

Does anyone know where I can get Modem driver for my Latitude D420 laptop? The Vista ones dont recognise the modem (Conexant D110,HDA,MDC,V92)

Thanks

Peter

0 Kudos
8 Replies
8 Krypton

Re: Latitude D420 Modem Driver Windows 7

Conexant D110,HDA,MDC,V92

 Drivers and Downloads

 


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

lankylad
6 Indium

Re: Latitude D420 Modem Driver Windows 7

Unfortunately thats the Vista driver that doesnt seem to recognise the modem

0 Kudos
8 Krypton

Re: Latitude D420 Modem Driver Windows 7

Vista Drivers are compatible with WIndows 7.  If devices do not enumerate correctly you have not installed the chipset drivers OR there is some other issue.


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

lankylad
6 Indium

Re: Latitude D420 Modem Driver Windows 7

OK thanks. I'll download the Vista Chipset drivers as well and see whether that helps

0 Kudos
lankylad
6 Indium

Re: Latitude D420 Modem Driver Windows 7

Doesnt seem to have made any made any difference. I cant see the modem when using Dell Diagnostics either, so I guess it must be faulty.

0 Kudos
8 Krypton

Re: Latitude D420 Modem Driver Windows 7

Is it disabled in the bios?


Report Unresolved Customer Service Issues
here

I do not work for Dell. I too am a user.

The forum is primarily user to user, with Dell employees moderating
Contact USA Technical Support






Get Support on Twitter @DellCaresPro

lankylad
6 Indium

Re: Latitude D420 Modem Driver Windows 7

No, its enabled

0 Kudos
8 Krypton

Re: Latitude D420 Modem Driver Windows 7

Doesnt seem to have made any made any difference. I cant see the modem when using Dell Diagnostics either, so I guess it must be faulty.

In your situation where you have installed drivers out of order, the chipset driver should be installed in Safe Mode. Then the NSS should be installed next.

If this doesn't work, OS re-install is necessary.

 

 

 

0 Kudos