Highlighted
marcochu
1 Copper

Latitude E4300 cannot detect SSD

Jump to solution

Hi,

I just bought a ADATA Premier Pro SP600 SSD (SATA III) and tried to install it on my latitude E4300. But the laptop cannot detect this SSD at all (including in BIOS). I've tried to switch it to other SATA mode such as ATA, AHCI, and IRRT but none of them work. I am very sure the SATA control works because it detects the off the shelf 80GB hard disk with no problem. Does anyone encountered this problem as well?

Note, my BIOS version is A23, I've tried A26 as well but it does work also.

Thanks

1 Solution

Accepted Solutions
Moderator
Moderator

RE: Latitude E4300 cannot detect SSD

Jump to solution

Hi Marco,

It seems to be unusual you are facing this issue the system supports SATA SSD. Please check if the hard drive is being seated properly into the hard drive slot. . I’d advise that you load defaults in the BIOS. Please follow the steps mentioned below to load the BIOS to defaults.

  1. Reboot the computer.
  2. When prompted during POST, press the <F2> key to enter the setup screen.
  3. On the System Setup screen, press the <F9> key.
  4. Press the <Enter> key on Yes to Load Optimized Defaults and restart the computer.

 

 

0 Kudos
6 Replies
Moderator
Moderator

RE: Latitude E4300 cannot detect SSD

Jump to solution

Hi marcochu,

The Dell Latitude E4300 can be configured with an SSD. You can use SATA operation AHCI on the system for hard drive detection. As the Normal mechanical drive is getting detected there seems to be no problem with the system board or the cabling. Please check if the SSD is detected on known good system.

0 Kudos
marcochu
1 Copper

RE: Latitude E4300 cannot detect SSD

Jump to solution

Hi Ravi,

I've just tried AHCI and it simply say it cannot detect the drive. I've tried testing the SSD on another computer as well and it works fine there. Is there any other possibility or BIOS setting I can try?

Thank you,

Marco

0 Kudos
anglogator
1 Copper

RE: Latitude E4300 cannot detect SSD

Jump to solution

Marco,

How do you have the SSD connected to the E4300? Also, what is your default SATA mode?

Thanks,

AG

0 Kudos
anglogator
1 Copper

RE: Latitude E4300 cannot detect SSD

Jump to solution

Also, what's the end game? Did you clone your HDD, and want to use the SSD as primary or primary/boot? If you cloned it, what software did you use and how did you go about the process?

I just did all of this last night. I have one hiccup left to address, however it went as planned. I'm guessing you have one of several small bits missing, then you're good.

Cheers,

AG

0 Kudos
Moderator
Moderator

RE: Latitude E4300 cannot detect SSD

Jump to solution

Hi Marco,

It seems to be unusual you are facing this issue the system supports SATA SSD. Please check if the hard drive is being seated properly into the hard drive slot. . I’d advise that you load defaults in the BIOS. Please follow the steps mentioned below to load the BIOS to defaults.

  1. Reboot the computer.
  2. When prompted during POST, press the <F2> key to enter the setup screen.
  3. On the System Setup screen, press the <F9> key.
  4. Press the <Enter> key on Yes to Load Optimized Defaults and restart the computer.

 

 

0 Kudos
marcochu
1 Copper

RE: Latitude E4300 cannot detect SSD

Jump to solution

It is now solved. Thank you very much

0 Kudos