Highlighted
breskmic
1 Copper

Latitude E5440 with Kubuntu 14.04 LTS: Two external displays are not working properly. (SOLVED)

Jump to solution

Hello, I am replaced my old, and still overheating, Latitude E6400 by new E5440, but I am found that my two external displays can be set properly now.

I am using two displays Dell E2210 connected to Dell port replicator PR02X via DVI.

This was working fine with old E6400 running Kubuntu 12.04 LTS, and I was able set displays in any manner - I was using one desktop spread through both displays mostly. But now on E5440 with Kubuntu 14.04 LTS system see both displays as one, I can't set anything regarding displays, and see the same content on both displays.

I am tried connect one display via D-SUB (VGA) or DP ports on port replicator, but result is still the same (VGA port on laptops body is not working at all. HDMI on laptops body was not tested because I am missing HDMI to DVI adapter).

Situation is the same regardless if Intel or nVidia is set as master graphic card.

According to http://www.ubuntu.com/certification/hardware/201307-13941/should be E5440 fully supported by Ubuntu and Dell (except nVidia Optimus), and this was reason why I am choose this model, so I hope that somebody will help me solve this issue.


Note1: My colleagues laptop which is exactly the same, but with Win 7 is working properly in my port replicator.

Note2: KScreen tool for settings displays in KDE desktop see my external displays as one device on port  DP1, and laptops own display as eDP1.

0 Kudos
2 Solutions

Accepted Solutions
breskmic
1 Copper

RE: Latitude E5440 with Kubuntu 14.04 LTS: Two external displays are not working properly.

Jump to solution

I am upgraded to Ubuntu 14.04.3 and Kernel 3.19.0-25 today (sudo apt-get install linux-generic-lts-vivid), and DP MST starts working like a charm. Problem solved.

breskmic
1 Copper

RE: Latitude E5440 with Kubuntu 14.04 LTS: Two external displays are not working properly. (SOLVED)

Jump to solution

I am upgraded to Ubuntu 14.04.3 and Kernel 3.19.0-25 today (sudo apt-get install linux-generic-lts-vivid), and DP MST starts working like a charm. Now is possible use two or more separated screens. Problem solved.

5 Replies
zhou52
1 Copper

RE: Latitude E5440 with Kubuntu 14.04 LTS: Two external displays are not working properly.

Jump to solution

Hello

I have the same problem with an XPS 15. It worked fine with kubuntu 12.04.

I could have an external monitor before in the HDMI port and configure it as second display

With 14.04, the display is recognized but it can be only a clone of the laptop display. The Ubuntu

System Settings->Monitor does not allow me to click on the "Set up..." button.!!!

I think this is an Ubuntu or KDE problem...

0 Kudos
breskmic
1 Copper

RE: Latitude E5440 with Kubuntu 14.04 LTS: Two external displays are not working properly.

Jump to solution

It looks that I am found reason - DisplayPort MST (Multi-Stream Transport) is needed, but it is not supported in Ubuntu 14.04 with kernel 3.13.x  yet.

Somebody is working on patch, but it will be available not before Linux 3.16.

So, lets wait for Ubuntu 14.10 and will see.

0 Kudos
breskmic
1 Copper

RE: Latitude E5440 with Kubuntu 14.04 LTS: Two external displays are not working properly.

Jump to solution

It looks that DP MST will be not before Linux 3.17 :-/

0 Kudos
breskmic
1 Copper

RE: Latitude E5440 with Kubuntu 14.04 LTS: Two external displays are not working properly.

Jump to solution

I am upgraded to Ubuntu 14.04.3 and Kernel 3.19.0-25 today (sudo apt-get install linux-generic-lts-vivid), and DP MST starts working like a charm. Problem solved.

breskmic
1 Copper

RE: Latitude E5440 with Kubuntu 14.04 LTS: Two external displays are not working properly. (SOLVED)

Jump to solution

I am upgraded to Ubuntu 14.04.3 and Kernel 3.19.0-25 today (sudo apt-get install linux-generic-lts-vivid), and DP MST starts working like a charm. Now is possible use two or more separated screens. Problem solved.