Laptops General - Read Only

Last reply by 11-27-2016 Unsolved
Start a Discussion
Not applicable

Latitude E6420 No Video No POST

Greetings - two days ago, I accidently flashed the BIOS for my E6420 with the E4310 BIOS rev A09.

When the system restarted, there was no video and the LED's indicated Memory failure (Off | Blinking | Off). Also, the battery charging indicator on the outside was flashing RED.

After reading up on the issue and knowing immediately that I'd used the wrong BIOS, I decided that removing / reinserting the CMOS battery was the appropriate solution.

Having done that, now, I have no LED's and the system is stuck in a loop where the fan cycles 13 or so seconds, the system emits a low volume beep and repeats. This is true IF the A/C power is left connected. Once disconnected, it stops.

I've tried holding Fn key down while pressing power to initiate ePSA, but there is no change.

I've also tried forced ePSA with no results.

Any suggestions are welcomed.

Thank you!

Reply (1)
10 Diamond

It's not possible to "accidentally flash" the wrong BIOS - the only way you could have done that is if you "force flashed" the wrong BIOS - i.e., bypassed the flash safeguards.  Are you certain that's what you did?

If it is, you have two options:

1.  Find a shop that can remove the BIOS chip, flash it in an EEPROM writer, and re-solder it, or

2.  Replace the mainboard.

These boards seem to run in the $120-175 range, meaning that if you can replace the board yourself, it'll likely cost about the same as (or slightly less than) option 1.

Latest Solutions
Top Contributor