bremen-pl
2 Iron

Latitude E6520 Docking station USB problem

Jump to solution

Hello there,

I dont really belive that anyone is abble to help me fix this problem but ill give it a shot coz this is reallt weaird and annoying.

So i am using an docking station to my dell, it has 5 USB ports (3 on the left and 2 on the back).

Now i am using a logitech wireless mouse. Whenever i plug the usb mouse receiver to any of the left ports, it works just fine. If I use any of the 2 on the back, it lags as hell and it seem to get stuck in every procces action, like moving files over explorer etc.

But thats not the most anyoing thing im expiriencing...

I wanted to make my life esier, so i bought a mini-pcie usb adapter, this one: 

And i plugged my mouse receiver to it- it works great! BUT WAIT, only if laptop is not connected to the docking station! If it is, im getting the exact same problem as i would connect the mouse receiver to the back of the docking station...

I tried reinstalling the root usb hubs but it havent changed anything. This is weird as hell.

I would really aprichiate if someone could help me with this problem. rly.

0 Kudos
13 Replies
Moderator
Moderator

Re: Latitude E6520 Docking station USB problem

Jump to solution

Hi bremen-pl,

It seems like an issue with docking station itself. If possible try this docking station on a different system to isolate the issue.

Also, let us know the version of windows installed on the system as we might need to update Chipset and BIOS of the system.

If you have any further queries, please feel free to contact us.

Thanks and Regards
Sandeep P
#iworkfordell

Thanks and Regards
Sandeep P
#iworkfordell

To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US Customers; UK Customers; India Customers. For Dell support videos click Here.

0 Kudos
bremen-pl
2 Iron

Re: Latitude E6520 Docking station USB problem

Jump to solution

Yhank you for the reply. This problem doesnt occur when i switch to debian operating system. 

Im using windows 7 64 bit pro.  

0 Kudos
Moderator
Moderator

Re: Latitude E6520 Docking station USB problem

Jump to solution

Hi bremen-pl,

Thanks for providing us this information. Please confirm that the issue doesn't occur once you checked on different windows installed on the same system.

Please check the link below to update the Chipset and BIOS drivers from the link below:

BIOS:

downloads.dell.com/.../E6520A17.exe

CHIPSET:

downloads.dell.com/.../Intel_Chipset-Software-Insta_A04_R304291_setup_ZPE.exe

downloads.dell.com/.../SWB_DRVR_ME7P1_5M_7_1_52_1176_A04_setup_ZPE.exe

Kindly perform these steps and let us know the results, so we can advise you further.

Thanks and Regards
Sandeep P
#iworkfordell

Thanks and Regards
Sandeep P
#iworkfordell

To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US Customers; UK Customers; India Customers. For Dell support videos click Here.

0 Kudos
bremen-pl
2 Iron

Re: Latitude E6520 Docking station USB problem

Jump to solution

Hi, i have no possibility to use other windows system here. I only have this windows 7 and linux. My bios was up to date and dell menagement engine was up to date too. I cant install the intel chipset driver it says its not for my sytems.

0 Kudos
Highlighted
Moderator
Moderator

Re: Latitude E6520 Docking station USB problem

Jump to solution

Hi bremen-pl,

Apologies for the delayed reply. I appreciate the time and effort that you took to troubleshoot the issue.

It seems issue is caused due to corrupt windows driver. Kindly remove the Chipset drivers from the system and re-install using the link above.

If you have any further queries, please feel free to contact us.

Thanks and Regards
Sandeep P
#iworkfordell

Thanks and Regards
Sandeep P
#iworkfordell

To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US Customers; UK Customers; India Customers. For Dell support videos click Here.

bremen-pl
2 Iron

Re: Latitude E6520 Docking station USB problem

Jump to solution

As i said i cant install the chipset one. It says its not for my system.

0 Kudos
Moderator
Moderator

Re: Latitude E6520 Docking station USB problem

Jump to solution

Hi bremen-pl,

Thanks for your reply. You can remove the drivers from the system and then install dell management engine on the system.

As, it works fine on Linux and issue occurs on Windows only then you can try clean re-installation of Windows on the system. Please check the link below which indicates the steps for performing the same:

http://dell.to/15MYHsz

If you have any further queries, please feel free to contact us.

Thanks and Regards
Sandeep P
#iworkfordell

Thanks and Regards
Sandeep P
#iworkfordell

To know more about Dell Product Support, Drivers & Downloads, Order & Dispatch status -> choose your region US Customers; UK Customers; India Customers. For Dell support videos click Here.

0 Kudos
bremen-pl
2 Iron

Re: Latitude E6520 Docking station USB problem

Jump to solution

I cant reinstall windows now. Which one shuld i reinstall exacly. Could u show it in device menager or in programs list?

0 Kudos
bremen-pl
2 Iron

Re: Latitude E6520 Docking station USB problem

Jump to solution

I fixed the problem, im not sure if this was the cause, but lemme show what i did:

So at the start, please look at this picture:

The way those 2 slots are populated is not natural- what i mean is that at the beggining i only had the wan card and one slot was free. But, before installing the usb dongle with its card i had to move the wan card from wan slot to sataflash slot and insert the usb dongle into wan slot. Why? See the place i circles (squared?) with red color. This metal border was to close and the dongle was to long so it wouldnt fit.

This way it was buggish and when i turned the switch my mouse wasnt working instead of wireless...

What i did to fix this problem:

I ripped off some of the metal borded using sharp pliers and replaced the cards to the proper slots (wan card in wan slot, usbdongle in sataflash slot).

Everything seems to be working so far.

Tags (1)