Laptops General - Read Only

Last reply by 08-04-2016 Unsolved
Start a Discussion
2 Bronze
2 Bronze

Latitude E7250 - doesn't detect my Windows 7 Professional USB reinstallation drive in UEFI mode

So, I've been trying to get all of the machines in our organization up-to-speed on the latest standards.  I figured that, as long as anyone is getting any NEW machine imaged and set up for them, that machine might as well be set up in UEFI mode, with GPT partitioning, as those are the latest standards for PCs.

We have a lot of Dell machines, and I have had no problem getting tons of them booting to my Windows 7 Professional installation USB drives, in UEFI mode, and installing a build of Windows in UEFI mode, using GPT partitioning for the drive.  E6320s, E6430s, E6440s, all work fine.

The Latitude E7250 doesn't even detect the USB drive that I plug into it, that has worked flawlessly for so many other machines.  I have the latest BIOS (A13).  Secure Boot is disabled.  I have tried plugging in the USB drive in a USB 2.0 port on the E-Port Plus docking station.  I have disabled USB 3.0. 

The machine does not detect USB devices in UEFI mode.

This is a laptop that costs north of $1,000, Dell.  For real?

Reply (1)
10 Diamond

This is not Dell's doing - it's Microsoft and Intel at work.  They removed the ability to boot Skylake-based systems from USB to install WIndows 7:

While you can find ways around it (see below), whatever reasons you have for running Windows 7 should be very seriously rethought now -- the Skylake platform is the very last Intel platform that will run 7 -- the soon to be released 7th generation (Kaby Lake) CPUs will not run Windows 7 at all.

Work around:

Top Contributor
Latest Solutions