375wea
1 Nickel

Re: Latitude XT3 - Worth the wait?

This  is from MS Forum and it worked:

Thank you so much for this! It was driving me crazy. I knew it had something to do with the power save but nothing in the Windows power options resolved it and no other resolution was found by Google.

When unplugged, the XT3 would have phantom presses all over the screen, but this would stop as soon as it was plugged back in. (Windows 8 64bit enterprise)

For anyone else having this problem:

1.Open the Intel Graphics and Media Control Panel (Right-click on the desktop and go to Graphic Properties)

2.Select "Basic" or "Advanced Mode" and hit "OK"

3.On the side, click "Power"

4.Next to Power Source, select "On battery"

5.Under Power Conservation Features, uncheck "Display Refresh Rate Switching"

6.Click "OK" at the bottom and Apply the settings.