Highlighted
chicrfc
1 Copper

Latitude e5420 plugged in, not charging. new dell battery installed

Hi all. My battery wouldnt hold a charge so i decided to replace it with a new dell extended life battery.

problem is, when i plug in the charger all i get is plugged in, not charging.

i have tried

1- removing battery and charger and holding power button for 20sec

2-deleted and reinstalled the battery drivers

3- loaded my bios by default

i have tried another dell charger, though mine is proper volts and amps also.

i have heard some people need to update bios, but i cant do this now battery is at 8% and i flung the old battery out.

any ideas?

Tags (2)
0 Kudos
2 Replies

RE: Latitude e5420 plugged in, not charging. new dell battery installed

Hi Chicrfc

Thanks for writing to us.

Please provide us the battery serial number (should start with either JP or KR or CN .

Also please load BIOS by tapping f2 during start and check the status of both charger and battery and let us know.

Do provide us the system tag# and also confirm the name the system is registered under. Let us

know the contact number and email address

Regards

DELL-Hemalatha P
Social Media Support
#IWork4Dell
Dell Support Videos 
Drivers and Downloads

0 Kudos
9 Rhodium

RE: Latitude e5420 plugged in, not charging. new dell battery installed

Check system setup. If the AC adapter shows unknown (F2 at powerup to check), that's the problem.

I order, try

1. A  new OEM Dell AC adapter -- if that doesn't solve the issue,

2.  Replace the DC power jack:

www.parts-people.com/index.php

and if that doesn't solve it, replace the mainboard.

0 Kudos