M6600 plugged in/won't charge

Jump to solution

Hi,

I'm trying to troubleshoot a used M6600 running Windows 10 with a battery that isn't charging (original battery and charger). When I plug the laptop to the wall (in either on/off states) the battery charge indicator flashes​ momentarily and then gone. I get the same result in different sockets.While plugged in Windows battery status indicator shows "plugged in/not charging". The battery doesn't charge when the laptop is left plugged in overnight while off​, nor does it stat charging if I insert it into an already running session.

I took several steps attempting to solve the problem, checking after each step before advancing. 

1. Updated to the latest BIOS from Dells website. It didn't solve the charging problem but enabling messages from diagnostics gets a message at Post notifying that the AC adapter isn't adequate for the laptop :"Alert! a xxxxxW AC power adapter has been detected, which is less the the recommended xxxxxW AC adapter originally shipped..."​

2. Unplugging the laptop, removing the battery, uninstalling both ACPI drivers and replacing the battery.(However at this point it became apparent that hardware is the source of the problem rather than Windows since the battery won't charge while the laptop is turned off while still plugged in).

3. Unplugging the laptop, removing the battery and pressing down the power button for 30 seconds in order to clear the CMOS, then plugging in and checking.

​4. Blew both onto the charger's plug and laptop's plug receptacle in order to remove dust.

5. Cleaned the battery contacts with a dry cloth.

How can I be sure whether it's the battery or charger at fault? Is the charger adequate for this laptop to begin with (65W 19.5V-3.34A AC adapter [model #LA65NS0-00])?

0 Kudos
1 Solution

Accepted Solutions
8 Krypton

RE: M6600 plugged in/won't charge

Jump to solution

It shipped with and requires a 240W adapter.

accessories.dell.com/.../PopupProductDetail.aspx

0 Kudos
6 Replies
Community Manager
Community Manager

RE: M6600 plugged in/won't charge

Jump to solution

Hi Petra, 

Thanks for posting.

In systems this old, the battery is probably the culprit, however the charging system may be suspect as well.  You may have to replace the motherboard, if you are unable to figure it out .  If the unit works with the ac adapter is plugged in, then the adapter is ok.


Dell-Robert P
Social Media Support
#IWork4Dell
To help us troubleshoot, please send us the Dell service tag number via a private message
Would you like to be a Dell Community Rockstar?


0 Kudos
Highlighted

RE: M6600 plugged in/won't charge

Jump to solution

Could it be a stronger indication that the charger is indeed at fault if- as I have found out now- when the GPU is stress-tested, or even under moderate load while watching Youtube at 1080p for example, the charger heats up very fast and both it and consequently the laptop shutdown abruptly?

I'm still unable to find definite information regarding whether PA-12 charger is theoretically even sufficient to power and charge the M6600. I'd really appreciate a definite answer for that because this info can be very beneficial in pointing me at the right direction if purchasing a replacement unit (the higher wattage ones are very costly).

0 Kudos
8 Krypton

RE: M6600 plugged in/won't charge

Jump to solution

The PA12 is 65W -- emphatically insufficient to run an M6600.

0 Kudos

RE: M6600 plugged in/won't charge

Jump to solution

Someone out there holds the key to the mystery which is the minimum power requirement to charge the elusive m6600 beast, nay- even RECOMMENDED by it's very creator- I feel it in me bones!

0 Kudos
8 Krypton

RE: M6600 plugged in/won't charge

Jump to solution

It shipped with and requires a 240W adapter.

accessories.dell.com/.../PopupProductDetail.aspx

0 Kudos

RE: M6600 plugged in/won't charge

Jump to solution

Thank you