Mouse/Touchpad not working.

Have a Dell e6420, running Windows 7 pro.


Mouse in Devices only has PS/2 Compatible mouse, installed automatically.

Touchpad is working, although there are no settings for it in the Mouse options. Impossible to increase sensitivity, and it's really slow. Attempted to download drivers from Dell website, tried touchpad drivers version 6, 7, and 11, none worked.

New mouse was installed, driver installed, Steelseries rival gaming mouse was recognized on the Steelseries application, but no response on screen, and error in the device manager. Indicates missing driver for Rival Gaming mouse. Auto-update doesn't produce anything but continues running, requiring shutdown through task manager.

I'm not sure where to look anymore, any advice would be appreciated.

Tags (2)
0 Kudos
1 Reply
Community Manager
Community Manager

RE: Mouse/Touchpad not working.

Hi tapir,

Thanks for posting.

Here is an article that may help, while it's not exactly the same issue you are having, it does address how to change the touchpad settings.

Please post back if you need additional assistance and the experts here will respond.  Thanks.


Dell-Robert P
Social Media Support
To help us troubleshoot, please send us the Dell service tag number via a private message
Would you like to be a Dell Community Rockstar?

0 Kudos