chowder138
1 Copper

No Dell touchpad settings for my Inspirion 17 7000, so I can't disable palm check.

I'm on a new Dell Inspiron 17 7000 2-in-1 laptop and I'm trying to disable palm check, AKA the setting that disables the touchpad for a few seconds after the keyboard is used. But in mouse settings, there's no Synaptics tab like on other laptops and there's no Dell-specific touchpad settings on the laptop that I can find. I've tried installing a few drivers but they either said they couldn't run on my device or just didn't do anything. I'm at my wit's end here trying to disable palm check.

0 Kudos
2 Replies
sofistek
2 Bronze

RE: No Dell touchpad settings for my Inspirion 17 7000, so I can't disable palm check.

You may be having similar problems to me and I couldn't find many of the settings mentioned in the Dell documentation, either. The WIndows 10 touchpad settings does show that I have a Precision Touchpad but without all of the settings I expected from the documentation. I have an Inspiron 15 7000 gaming laptop.

It did help when I set all of the three and four finger settings to do nothing. The only problem I'm really left with (apart from not being able to use 3 and 4 finger gestures) is the all touchpad click. So that, when I'm typing and my palm accidentally clicks the touchpad, the cursor zooms to where the pointer was last positioned and I end up typing somewhere else, needing to correct that before continuing. It's really annoying and common (the touchpad is large).

Having the touchpad disable when typing would solve this, so I guess this is the same setting you're looking for and any help from the community or support guys would be appreciated. I certainly wasn't expecting to click on the touchpad itself, rather than just on the pseudo button at the bottom of the touchpad, so turning of that click would be great but disabling the touchpad entirely whilst typing wold also work.

0 Kudos
Humbirdz
2 Bronze

RE: No Dell touchpad settings for my Inspirion 17 7000, so I can't disable palm check.

The setting for touchpad drivers is in windows settings and can be disabled from there. Go to settings>Devices. Touchpad and toggle the switch to off. It also has a check box to disable touchpad when a mouse is connected. All touchpad settings are there for a precision touchpad.

0 Kudos