Highlighted
Not applicable

No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

Just got a D/dock for my d630. Everything seems to work except for the 3.5 mm audio jack; when I insert the audio cable for my external speakers into the jack the laptop's speakers turn off but there is no sound from the external speaker. Tried updating BIOS and reinstallin Sigmatel audio driver; any ideas would be greatly appreciated!

0 Kudos
2 Solutions

Accepted Solutions
Highlighted
Not applicable

RE: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution
0 Kudos
Highlighted
Not applicable

RE: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

Importatnt! when installing R171788 the speakers must be switched on and plugged into the dock station to allow reckongnize them by the driver. It helps in my case.

cheers! 

View solution in original post

0 Kudos
21 Replies
Highlighted
Not applicable

Re: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

I have the same problem, but with the D/port.  I'm running Windows 7 64-bit RC.  I seemed to have this problem starting with Vista 64bit, so I'm gonna go out on a limb and think that it's the 64bit audio drivers for the D-port and D/Dock that are part of the problem. 

Symptom:

  • When D630 running Vista 64bit or Windows 7 64bit is docked into the D-Port, all sound is directed through the laptop speakers
  • Plugging in headphones/speakers into the d-port audio jack does nothing.
  • D-port audio is not recognized or shown in device manager
  • I *can* plug in speakers or headphones into the left side of the laptop... the onboard headphone jack and it silences the laptop speakers correctly.
  • USB headphones (plantronics headset) work just fine in dock or out of dock
  • I tried this initially on D630 BIOS A13.  Upgraded to A16, no change. (not sure if laptop bios would affect this, or maybe d-port firmware? I couldn't find d-port in support.dell.com but I could find c-port.  That was odd)

Suggestions?

Highlighted
Not applicable

Re: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

I am running Windows 7 Pro 32-bit and am experiencing this same issue. Not a big deal, as I can plug my ext speaker audio cable into my laptop, but its definitely a nuisance...

0 Kudos
Highlighted
Anonymous
Not applicable

Re: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

Not sure about the clicks for Vista or Win7, but you might want to look at sound properties and check what is showing as the default speaker. Mine says "Desktop Stereo Speakers" and works via the docking station. Let me know if you don't find it, and I'll grab a Vista box and a Win7 box, and see what I find.

0 Kudos
Highlighted
Not applicable

Re: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

I thought I had installed the Vista 32-bit sound driver from the dell support site (to use in W7 32bit), but had not.

I installed the driver, rebooted, and now the sound port works at least for Windows 7 32-bit version.

Thanks,

-gabe

0 Kudos
Highlighted
Anonymous
Not applicable

Re: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

Good to know. Thanks for posting back.

0 Kudos
Highlighted
Not applicable

Re: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

I recently reloaded my D830 from scratch with Windows 7 Ultimate. The audio from the D/Dock would not work.

I solved the problem by using the VISTA 32 BIT Sigmatel audio drivers from the Dell Support Site.

You might also try the D/Dock FX-2 update. FX2_A04.EXE

0 Kudos
Highlighted
Not applicable

Re: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

I have Win7 64 bit installed and cannot find the appropriate drive to install. I am having the exact problem as Gabe. Please Help!

0 Kudos
Highlighted
Not applicable

Re: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

I also have a D830 with Sigmatel sound. I just installed Win7 64bit Ultimate from scratch and get no sound from D Dock headphone jack. Jack on laptop worked fine. I installed the Vista 64bit Sigmatel driver and that fixed the problem. The file was R171788.exe

Highlighted
Not applicable

Re: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

I also have a D830 with Sigmatel sound. I just installed Win7 64bit Ultimate from scratch and get no sound from D Dock headphone jack. Jack on laptop worked fine. I installed the Vista 64bit Sigmatel driver and that fixed the problem. The file was R171788.exe

R171788.exe worked for me as well.  I am using Windows 7 64-bit as the OS and was having trouble with my Dell Docking Station headphone jack using a D630 machine.  Once I installed the driver, the headphone jack on the docking station turned on and was working properly!  Good answer.  Thanks!

0 Kudos
Highlighted
Not applicable

Re: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

Thx for this, couldn't solve this for some time.  The regular R171789.exe does not work on my D830 but the R171788 dit it.

I use Windows 7 Ultimate 32 bits.

Thx for sharing.

0 Kudos
Highlighted
2 Bronze

Re: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

I recently reloaded my D830 from scratch with Windows 7 Ultimate. The audio from the D/Dock would not work.

I solved the problem by using the VISTA 32 BIT Sigmatel audio drivers from the Dell Support Site.

You might also try the D/Dock FX-2 update. FX2_A04.EXE


Thanks for your sharing! It's comprehensive, This is what I'm looking for, Now I understand more about it.
0 Kudos
Highlighted
Not applicable

Re: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

This worked for me. Thank you for sharing!

Highlighted
Not applicable

RE: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

I would install the hd audio driver.

Here is the link.

http://www.dell.com/support/drivers/us/en/19/Product/latitude-d630

0 Kudos
Highlighted
Not applicable

RE: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution
0 Kudos
Highlighted
Not applicable

RE: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution
I found a workaround. Here goes (follow each step exactly - don't get ahead of yourself):

1. Download the VISTA sigma-tel driver for either 32 bit VISTA or for 64 bit VISTA from the Dell website. This 32 or 64 bit choice should correspond to your version of Windows 7. After downloading, create a folder on your desktop called "audio" or similar - something easy to find. Download the driver package to that new folder.

2. Run the installer which asks you where you want to place the installation files as they unzip. Choose the folder that you created in step 1 and extract the files into the same folder. You will have to type the path manually.

3. Once the installation files have been unzipped and are in the file that you created, you will notice that there are several files named "Setup". RIGHT CLICK once on the setup file that bears the InstallShield icon. After right clicking the correct setup file, select "Troubleshoot Compatibility". This is new for Windows 7. You will be asked to specify the program in which the driver USED to work. Indicate VISTA 32bit or 64bit, again depending on the version of Windows 7 that you are using. Continue following the prompts, and the driver then installs properly and all audio outputs function properly on both the laptop and the docking station.
0 Kudos
Highlighted
Not applicable

RE: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

thank for the help but it just didn't work. I install this driver but the speaker sign on the taskbar  shows that the computer has sound but its not coming out of the laptop speaker neither is it coming out of the head phone.

Is there any other thing you could suggest?

thank

Joseph Mensah

0 Kudos
Highlighted
Not applicable

RE: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

Importatnt! when installing R171788 the speakers must be switched on and plugged into the dock station to allow reckongnize them by the driver. It helps in my case.

cheers! 

View solution in original post

0 Kudos
Highlighted

RE: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

This problem has been plaguing me for a long time. Sometimes the driver works, and other times it does not. Maybe it's a chipset driver problem. I have a d630. I've been able to get dock audio on win7, win 8.1 and win 10, all 64 bit, but on some installations it just won't work no matter what. The audio is there for a split second, and then it's gone. It can't be a bios issue since it works sometimes.


Really wish I could put this problem to bed.

0 Kudos
Highlighted
Not applicable

RE: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

R171789 isn't working for me. Only the R171788... Good luck!

0 Kudos
Highlighted
Not applicable

RE: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

Hi, AlexChato9's workaround works fine on Windows 10 too. I've downloaded the XP driver R171789.exe and executed in compatibility mode the way you suggested

Win 10 tried to install it using the default settings (XP), and currently anything is working fine.

No need to reboot the system.

Thanks a lot to you and to Medienfox

0 Kudos
Highlighted
Not applicable

RE: No audio from 3.5 mm jack on d/dock port when d630 docked, vista business

Jump to solution

THANKS!  This outdated thread help my still alive D820 running windows 8.1 - although I seldom use it.  

I have an E6510 running linux, I've been off windows for years.  Admittingly as far as windows goes, the old D820 doesn't have any real problems keep up with 8.1

0 Kudos